Notice! This document is currently in Archived status.
The content of this document may be incorrect or out dated.

Thunderbird for Mac IMAP Client Setup

Thunderbird is a popular free e-mail client for Macintosh and Windows. Download the latest version from Mozilla's web site. These instructions describe how to configure Thunderbird on a Macintosh as an IMAP client for a mailbox on an ECN server. If you have mailboxes on both ECN and ITaP Exchange (which is usually a temporary situation), you may move messages from one server to the other.

For an ITaP Exchange mailbox instead of (or in addition to) an ECN server mailbox, see our Thunderbird for Mac Exchange client instructions

Windows users:  For an ECN mail account, see our Thunderbird for Windows instructions. If your mailbox is on the ITaP Exchange server, ECN recommends that Windows users set up Microsoft Outlook.

Thunderbird 2.x and 3.x have different "new account" setup dialogs, but have the same advanced settings. Follow the appropriate instructions for the version of Thunderbird that you are running to get started, followed by the generic server settings which are the same for all versions.

Thunderbird 3.x New Account Setup

During the first launch of Thunderbird, or when selecting to create a new account, fill out the following information:

  • Your name: Your name as you wish it to appear. This is not your username or your email address
  • Email address: Your career username followed by @purdue.edu.
  • Password: Your career account password

Mail Account Setup Dialog

Thunderbird should automatically find the settings for both the incoming IMAP server and the outgoing SMTP server. Click Create Account when finished.

 


Synchronization (Thunderbird 3) - For ECN Domain Mac users only:

This setting is only for users who log onto ECN Domain Macs using their career name and password. These users have their home folders stored on a server, which has a quota. The following steps to turn off synchronization in Thunderbird 3 reduces the amount of space used on these accounts, and speeds up Thunderbird. It should not be used or needed on portables (notebooks) or other machines where the user has an account stored on the machine, where space is not an issue, and email needs to be able to be accessed while offline. These users, with local accounts, can skip this step.

From Thunderbird, click the Help menu, and select Migration Assistant.

Mac OS X Search

Click the button labeled "don't synchronize any".

Synchronize IMAP Messages Properties

The Migration Assistant tab should change to show the following:

Synchronize IMAP Messages Properties

 

 

Before attempting to retrieve your email, skip to step 7 (Server Settings) below and continue to complete the setup.


New Account Setup Dialog

Thunderbird 2.x New Account Setup

1. Launch Thunderbird. The first time you launch Thunderbird, the program will likely take you into its Account Wizard dialog (see the illustration, right).

  • If Thunderbird asks you about importing settings and mail folders, select "Don't import anything" and click the "Continue" button.
  • If Thunderbird does not take you into its Account Wizard dialog, click on the Tools menu and select "Account Settings"; then click the "Add Account" button.

Select the "Email account" option.

Then click the "Continue" button.

 

 

 

 

 


Identity Properties2. Identity.

2A. In the "Your Name" field, type your name as you'd like it to appear in outgoing messages.

2B. In the "Email address" field, type your address in this format, specifying your own Purdue Career Account username:

username@purdue.edu

2C. Then click the "Continue" button.

 

 

 

 


Server Information Properties3. Server information.

3A. For the incoming server type, select "IMAP".  (It is very important not to miss this! The dialog should appear only as shown in the illustration at right. ECN does not recommend using "POP".)

3B. In the "incoming server" field, type the specific name of your ECN home server in this format:

server.ecn.purdue.edu

There are many ECN mail servers (including dynamo, fairway, gilbreth, min, shay, and many others), but only one specific server name is valid for you. If you're not sure which server your mailbox is on, please contact us before proceeding.

3C. In the "outgoing server" field, type exactly the following:

smtp.ecn.purdue.edu

Regardless of the server name you used in step 3B, everyone should use smtp.ecn.purdue.edu for step 3C.

(If you're adding the ECN server as a second e-mail account, Thunderbird might not ask for an outgoing server value here. You'll need to tweak outgoing server settings later.)

3D. Then click the "Continue" button.

 

 


Username Properties4.  User Names.

Thunderbird should have already filled in the "incoming user name" and "outgoing user name" fields for you.  Your Purdue Career Account username is the correct value.

Click the "Continue" button.

 

 

 

 


Account Name Properties5. Account Name.

The "account name" field's setting won't have any effect on your ability to send or receive messages, but we suggest entering the following value in this field:

My ECN account

Then click the "Continue" button.

 


Verify Information6. Verify information.

Thunderbird presents a dialog with a summary of the information you've entered so far.

If you see no obvious errors, click the "Continue" button.

 

 

 

 

 

 


Login AlertDisabled login alert.

Thunderbird will likely present a dialog which reads "You cannot log in to server.ecn.purdue.edu because the server has disabled login. You may need to connect via SSL or TLS. Please check the account settings for your mail server."

This alert message is normal. Click the OK button.


Server settings

Tools/Account Settings7. Click on the Tools menu and select "Account Settings."

 

 

 

 

 

 


Account Settings Dialog8. Account settings dialog.

8A. In the left-hand column beneath "My ECN account,", click on "Server Settings."

8B. In the "Security Settings" area, select "SSL".

8C (optional step). Enable the "Empty Trash on Exit" option. This tells Thunderbird to erase the messages you had previously deleted from your Inbox or other folders.

8D. Click the "Advanced" button. A new dialog will appear.

 

 

 

 

 

 

 


Advanced Settings Dialog9. Advanced settings.

9A. In the "IMAP server directory" field, type exactly the following:

~/mail

9B. Disable (uncheck) the "Server supports folders that contain sub-folders and messages" option.

The default values on all other options in this dialog are fine.

9C. Click the "OK" button.

 

 


Outgoing Server Properties10. Adding or editing the outgoing server.

10A. In the left-hand column, click on "Outgoing Server (SMTP)".

10B. Click the "Edit" button. (If the outgoing server "smtp.ecn.purdue.edu" is not already listed in the dialog, click the "Add" button instead.)

10C. In the "Description" field, type (or verify) the following:

smtp.ecn.purdue.edu

 

10D. In the "server name" field as well, type (or verify) exactly the following:

smtp.ecn.purdue.edu

Outgoing Server Settings10E. In the "Security and Authentication" area, near the lower right corner of the dialog, select "SSL".

10F. Then click the "OK" button.

10G. Finally, click the "OK" button to dismiss the account settings dialog.

 

 

 

 

 

 


 

Select Mail Server Settings11. Setting your ECN account's outgoing server.

11A. In the left-hand column, click on "My ECN account."

11B. On the right-side, there is a pop-up menu next to "Outgoing Server (SMTP)". From this menu, select the entry which begins with "smtp.ecn.purdue.edu". (The entry which begins with smtp.purdue.edu, if it exists, is not the one to use here.)

11C. Finally, click the "OK" button to dismiss the account settings dialog.

 

 

 

 

 

 


Unable To Verify Server Dialog12. Check mail.

12A. Click the "Get Mail" button on Thunderbird's toolbar.

12B. When prompted, type in your Purdue Career Account password and click the "OK" button.

12C. If you see an "unable to verify server.ecn.purdue.edu as a trusted site" message, you may select the "Accept this certificate permanently" option and then click the "OK" button.

 

 

 

 

 

View of Inbox12D. In the folder list on the left, click on the Inbox.  Your e-mail messages will appear at the right.

 

 

 

 

 

 

 

 


Moving or copying messages from one e-mail server to the other

Moving/Copying Messages

The software which runs ECN's e-mail servers is quite different from the ITaP Exchange server's software;  each server supports e-mail folders in a unique way. As such, to copy messages from one server to the other seems to work most reliably when you copy or move the contents of each folder one by one. This is what you'd need to do if, for example, you're in the process of migrating from an ECN mailbox to an Exchange mailbox, or vice versa.

Also, the servers might not support nested folders when accessing them via IMAP protocol.

13. Subscribe to your existing folders.

If you have stored e-mail in folders other than your Inbox, those folders might not be visible in the left-side column in Thunderbird until you subscribe to them.

13A. Right-click (control-click) on your Inbox or another existing folder. From the menu which appears, choose "Subscribe."

13B. In the dialog which appears, put a check-mark in the box on the line for each folder which should be visible in your folder list.

13C. Click the "Subscribe" button.

 


Moving/Copying Messages14. Copying or moving messages.

14A. Using the left-hand column, select the folder from which you want to copy or move messages.

14B. In the list of messages, select the messages that you wish to copy or move.

To select multiple messages, you may shift-click to select a contiguous range of messages or command-click individual messages one at a time. If you want every message, click on the Edit menu and choose "Select All."

14C. Click on the Message menu, choose "Move" (or "Copy," if you prefer), and navigate to the specific destination folder shown in the submenus.

Alternately, after selecting the messages in step 14B, you may right-click (or control-click) on one of the selected messages. A context menu will appear with the same "Move" and "Copy" commands.

 

Last modified: 2012/02/09 12:28:57.496254 US/Eastern by sundeep.rao.1
Created: 2009/03/31 09:33:5.311000 GMT-4 by john.a.omalley.1.

Categories

Search

Type in a few keywords describing what information you are looking for in the text box below.

Admin Options: Edit this Document