
Milling Machine Policies 
This milling machine must be used by only qualified users. A qualified user list is posted 
beside the machine. If you want to learn how to operate the milling machine, first find the 
superuser who will post you on the trainee list. A qualified user may train trainees and 
will let the superuser know who is being trained and qualified. Read through the 
following document before training.  
https://engineering.purdue.edu/IDEAS/Facilities/SOPMill.pdf.  
 
Before milling 

 Be aware of the milling machine policies and standard operating procedure. 
 Sign in on Mill User Use Log. 
 Check that chuck look is up to avoid burning out motor. 
 Make sure to verify the depth of every single tool before pressing “START” button to make 

sure that there is no further damage to the milling plate. The head can be pressed down in the 
“zero” position to check penetration depth. 

While milling 
 In the case of an emergency, either turn off the milling machine or pull up the head to prevent 

further damage. The “Stop” button is usually not effective because of the command buffer.  
 If damage is done, be sure to properly dispose of the damaged bit and sand down any burs 

introduced to the milling plate to keep the face as flat as possible. Write down the details of 
damage in Sign In sheet and let the superuser know immediately.  

 When you contour routing, keep looking to see if the contour bit goes down. If so, shut off 
the machine immediately. 

After milling 
 Organize as shown in the following figure for the next user. 

 



 “Standard tools” are tools that are used on almost every build, which is why they are good 
candidates for our use of the “odometer” system. Only standard tools belong in “Standard 
Tool Box”. The following are standard tools:  

 
      No other tools belong in this box. The reason for this is that the standard tools are all 

easy to identify, but drill bits and other strange end mills are hard to distinguish from 
one another (especially drill bits…a 0.3mm drill bit looks a lot like a 0.4mm drill bit, 
etc.) Do not use standard bits that are not in the “Standard Tool Box” box unless you 
are replacing a worn-out bit.  

 When the life of a tool is ended or broken, replace it with one from stock and throw the old 
one in the sharps disposal unit. Do not put it in “Questionable bit box”. 
 

 If a bit is around but you do not know what the bit is, then put it in “Questionable bit box”.    

 
 

 If a bit breaks or clearly wears out before the end of its lifetime, replace it and click on 
Configuration  Tool Library Mill/Drill…and then click on “Replace” to manually reset 
the lifetime. 
 

 Superuser: Seongheon Jeong, jeong11@purdue.edu, 206-356-8468 



Standard Operating Procedure for using the IDEAS lab 
milling machine 
 

Design Item to be Milled 
Ansoft Designer 

1. From Ansoft Designer (Project->Insert Planar EM Design to start, select any 
Duroid material) 
2. If you need a complicated shape for your cutout outline, draw it on a different 
layer. 
3. After you have finished with the board layout, go to Layout-> ExportFile.  
Select file type GERBER (*.ger) 
4. If your layout has only one layer, first delete all the Pages except one.  Under 
“Layers”, select the “Trace” Layer (default), and deselect any others.  Each layer 
should have its own page with only it included. 

 
Also, remember the values you select for Significant figures, Zero Suppression, 
and Units, as sometimes the file header can become corrupted and not transmit 
this information correctly.  The different layers could be out of scale without these 
values. 
 
4. If you have via holes, go to Layout-> ExportFile.  Select file type NC Drill File 
(*.ncd) 

 
 



5. Bring the files to the computer next to the milling machine. 

6. Open Circuit Cam. 5.0 CircuitCAM 5.0.lnk  
Agilent ADS 

1. Layout board in ADS.  This can be done by moving a schematic to layout and 
then adjusting the layout to your liking.  You can use rectangle tools, trace 
tools etc.  All that matters are the layers.  There will be (in general) a hole 
layer, a conductor layer, and a bound layer.  Flatten all components and 
remove excess layers not needed for alignment (things like text, and others).   

2. Draw a rectangle on around your design on the ‘bound’ layer. 
3. Choose File->Export.  Choose ‘File Type: Gerber’, then ‘More Options…’ 

 
In ‘More Options…’ ensure that the Hole Format is set to ‘Preserve Holes’ 

 
Click OK, then OK. 
4. Press ‘Gerber file options’ in the window that comes up.  The correct settings 

are shown.  Hit OK to return. 

               
5. Press ‘Translation settings’.  The correct settings are shown, the only change 

is to set ‘Gerber Output Format’ to RS274X. Hit OK to return. 



 
6. Click ‘Edit Aperatures’.  From here click ‘Flash 

Circles/Rectangles/Polygons’. 

 
7. In ‘Show’ unselect ‘Rectangles’ and ‘Polygons’.  Check that the remaining 

two apertures correspond to the holes and or pads.  In this design there are 4 
separate 1 mm holes.  There is a pad with a 4 mm diameter. 

 



8. Select ‘Translate’.  Then with all layers selected (or only the ones you want to 
export) click OK. 

 
9. Click “View Gerbers”.  Click the ‘Fill’ button on the left to switch to outline 

mode.  Make sure the circuit looks like you expect it to.  

 
10. Click the ‘Aperture’ button, then find the one in the list with the same ‘X 

(mm)’ dimension that matches your drilled hole diameter.  In the same line 
with that aperature label it ‘Tool #’ 1.  Then specify the ‘Drill Diameter’ in the 
same line.  Below is the example for my design which includes 4 1 mm holes.  
Line 18 corresponds to the hole aperture.  

 
11. The drill file can be checked as follows: Go to Tools->Drill->Excellon 

(Leading Zero Suppress).  In there select the layer with your holes on it, then 
click report.  This displays the notebook file below.  There is one row in the 



table, thus there is only one size hole.  It is 1 mm in diameter and there are 4 
of them.  This is all correct, so we proceed. 

  

 
12. The Gerber files should be in the project directory of your ADS design labeled 

as ‘cond.gbr’, ‘cond2.gbr’, ‘hole.drl’ etc.  For layers with conductor or the 
boundary layer copy the *.gbr files.  For the drill layer copy the *.drl file. 

 

Process Gerber File using Circuit Cam 
1. Import: 

a. Select File->Import, and choose your gerber file.  Select the correct file 
then select the correct layer (top or bottom) in the dialog box, and hit 
Preview to verify that it is the correct one.  Then hit Import. 

b. Repeat this step for each layer, and also for the drill file (if any).  Preview 
each layer to make sure that the overall dimensions are in the ball park 
(not several meters). 

2. Board Outline: 
a. If you haven’t drawn a board cutout outline yet, select “BoardOutline” in 

the first dropdown menu, then draw a rectangle around your design.  The 
border of this rectangle will be the contour that the mill will cut along to 
separate your board from the sheet of raw substrate, so size the rectangle 
appropriately. 



b.  
c. Select the rectangle that you just drew by clicking on the corner you 

started drawing it from.  Hit the Contour Routing button (arrow) and fill 
out the specifications window as shown:   

 
d. Hit Run.  A routing contour will appear around the rectangle you drew, 

rounding off its corners.  This is the path the cutting router will take.  You 
don’t need the rectangle anymore, so select it and delete (objects are 
selected by clicking in the corner you started drawing them from- usually 
the top-left corner). 



3. Define Breakout tabs: 
a. Select the routing contour by clicking on its top left corner. 
b. Hit the ‘–‘or ‘+’ key until the diamond or square on the long side of your 

contour becomes an asterisk.  The two keys move the asterisk clockwise 
and counterclockwise around the contour.  

 
c. Hit the Breakout Tab button (arrow in figure above) to define a breakout 

tab where the asterisk is.  Then move the asterisk to the opposite face of 
the routing contour, and define another breakout tab.  

 
d. This example shows 2 breakout tabs (below).  You might want to make 

four if your design is large. 
 
 
4. Rubout level:  Now you need to specify whether you want all conductor removed 

between your components, or just an insulating trench cut between them. 



 
a. Rub Out All:  Hit this button and draw a rectangle around the area where 

you want all non-used conductor to be removed (see below). 

b.  
c. Insulate All:  Hit this button and draw a rectangle around the area where 

you want all only an insulating trench cut around your conducting 
features. (see below) 

 
5. Defining insulate areas. 

a. Choose Edit->Insulate 



 
b. Fill out the window as shown, with the Standard, Big, and Bigger tools.  

Layout tracking refers to the direction the cutting head will track across 
your design as it is cutting out the insulating layers- vertically or 
horizontally.  Choose whichever makes more sense for your design.  After 



you hit Run, you should see the tool paths outlined like this: 

 
6. Choose File->Save As and save the design as a *.cam file. 
7. Hit the Export to Circuitboard Plotter button, and a .lmd file will be written to the 

same directory you chose to save you file in during the previous step. 
 

Operating the Milling Machine 
 

1. Flip on the power switch on the bottom left of the mill machine. 

2. Open Board Master on the mill computer BoardMaster 5.0.lnk  



3. Change the layer dropdown menu to “Milling Top” 

 

4. Hit the Pause  button.  The cutting head will move out of the way. 
5. Load the duroid onto the mill, with the set pins through the alignment holes in 

the duroid sheet.  Tape the duroid sheet down onto the mill with the blue 
masking tape.  If you are using a new sheet of duroid, an explanation of how 
to create alignment holes in it can be found in Appendix A: Creating 
Alignment Holes in a New Sheet of Material. 

6. The large gray area on the Board Master display corresponds to the milling 

platform on the mill machine.  Hitting the  button and then clicking on 
the gray pane will cause the mill’s cutting head to move the corresponding 
position on the milling platform (try it).  The top left corner of the screen 
corresponds to the bottom left corner of the mill. 

7. Find an area on the duroid sheet with enough blank space to accommodate the 
design your want to machine.  Move the milling head to the (screen 

orientation: bottom-left) corner of this area by hitting the  button and 
clicking on the screen.  Go to Configuration->Material->Set Low Corner.  
Now move the milling head to the opposite (screen orientation: top right) 
corner of the area you’ve chosen, and choose Configuration->Material->Set 
High Corner.  A rectangular area defined by these two points will be grayed 
out on the screen. 



8. Go to File->Import->LMD, and select the file output by CircuitCam. Your 
file circuit board will be superimposed on the rectangular area you defined, 
and you’ll be able to see if there’s room enough to cut out your design.  If 
there isn’t you can redefine the rectangle by the same procedure, and you can 

move your design image by hitting the  button.  Here’s an example: 

 

9. Now you’re ready to start the mill.  Hit , then hit the big  
button. 

 

Tool Setup and Calibration: 
 

1. You must have had training in order to use the mill—this part of these instructions 
is intended only as a reference and reminder, and will not be sufficient to instruct 
you in operating the mill by itself.  Tool change out is the most critical part of the 
whole procedure of milling a board because if done incorrectly you can damage 
the machine and possibly yourself.  Pay careful attention to detail while changing 
and calibrating tools on the mill.   



2. This is the pane that will appear to prompt you to change out a tool.  

 
3. The first thing you should do is check the radio button to “Stop after tool 

exchange for adjustment” as shown, so you can calibrate the tool to cut at the 
correct settings. 

4. Push the chuck tightener down and loosen it until the bit already in the mill falls 
out into your hand.  Do not let the bit fall onto the table, as this will damage the 
tip.  Select the correct bit from its caddy and place it into the cutting head using 
the tweezers.  Tighten the chuck hand tight, then pull up on the tightener until it 
pops back up.  Always remember to pop the chuck tightener back up.  If you 
forget to do this and start the machine, the mill motor will stall and be damaged. 

5. There are two types of milling heads—90 degree taper heads and fishtail heads.  
If the tool you desire to calibrate is a 90 degree taper (such as a Universal Cutter 
tool) follow steps 6-9 below.  If the tool has a fishtail cutting head (eg the 2.0 mil 
End Mill), follow steps 10.  Here is an image of the most commonly used bits: 

 



6. Taper Head tools Move the cutting head to a scrap area on the duroid sheet and 

cut a test path using the  controls.  The text box in the center 
specifies the length of the test trench in millimeters, and the buttons indicate the 
direction to cut (starting from the current location). 

7. Specify 5 millimeters in the text box, and hit the  to start the cutting head 

rotating.  After it has come up to speed, lower the head using the  button and 
cut the trench by hitting one of the direction buttons.  After the trench is cut, raise 
the cutting head, stop the rotation, and move the cutting head away and use the 
microscope to measure its thickness. 

8. Rotate the mill height adjustment to adjust the trench thickness—moving the bit 
down will cause the trench to be wider, and moving the bit up will cause the 
trench to be narrower, in increments of about ¼ millimeter per click.  Move the 
cutting head back to cut a new test trench. 

9. Iterate steps 7 and 8 until the desired cutting thickness is achieved. 
10. Fishtail head tools.  Calibrate this tool by cutting not a trench, but merely a 

single point.  Spin up the cutting head, then simply lower and raise the tip.  This 
type of tool is correctly calibrated when the edges of the cutting head just barely 
cut through the conductor, leaving a hole like a donut with conductor still intact in 
the middle.   

11. Drill bits.  If the tool is a drill bit, move the milling head to the lower right corner 
position.  Manually push the milling head downward and check that the drill bit 
will cut through the duriod sheet and part of the protective piece of cardboard, but 
not into the metal plate of the milling machine.  Adjust as necessary by rotating 
the mill height adjustment. 

If areas of conductor aren’t removed completely 
 

1. Because the duroid board isn’t perfectly flat, areas of conductor may not be 

completely removed after they’ve been milled out.  If this happens, hit the  

button and draw a box around the area you want do redo.  Then hit the  
button and push start. 

 

Machine Shutdown 
 

1. After your sample is done being milled, hit the  button and remove the 

duroid board.  Then hit the  button to return the cutting head to the home 
position, and close Board Master.  After the cutting head has gone to the reference 



position, shut the power off.  Close the valve on the nitrogen bottle, and turn the 
black control knob on the regulator all the way to the left. 

2. Close the mill enclosure. 
3. Pop your sample out using the breakout tabs, and use scotch brite to remove any 

burrs from the copper surface. 
 

Appendix A.  Creating Alignment Holes in a New Sheet of 
Material 

1. Load the 2.95mm (or 3 mm) spiral drill bit into the milling head.  Remember to 
pull up the chuck tightener and check the depth that the drill will penetrate. 

2. Securely tape down the sheet of material offset about 1 cm to the left or right so 
you aren’t redrilling the alignment holes in the protective board. 

3. Command the milling head to move to the Home   position. 

4. Using the  controls, move the milling head 25mm toward the front 
of the machine, toward you, left on the controls. 

5. Drill a hole by spinning up the motor with the  button and punch the hole 

with the  button.  Stop the bit with the  button. 

6. Using the  controls, move the milling head 287mm toward the 
back of the machine, away from you, right on the controls 

7. Drill another hole by following the steps in step 5 above. 
8. After both holes have been drilled, insert the set pins with the curved sides down.
 

Appendix B.  Plating Vias – Steps 
Note:  To use the plating equipment you must be properly trained.  This list serves as a 
reminder of the steps to those who have been through the training. 

1. Put on PPE – coat, goggles, gloves. 
2. Coat vias with conductive Ink. 

a. Use bottle to apply a coat of ink on all vias. 
b. Use squeegee to force ink through the vias. 
c. Use wet/dry vac to clean excess ink from board.  Be sure to place hose 

back in eye wash station. 
3. Bake board 

a. Set oven to Heat, press power 
b. Hold set point button and adjust knob to 100. 
c. Place board in oven for 1 hour. 



4. Calculate current and time for plating: 
a. Current: (Asub is copper area submerged in [ft2] don’t forget both sides) 

5subI A= ×  
b. Time: (tplating is the plating thickness in [in.]) 

[ .]
[ ] *60

.000275
platingt in

Time mins =  

5. Remove extra conductive ink from surface of board 
a. Use tray, scrubber, and powder to remove all excess conductive ink that is 

on the surface. 
b. Dip the board in Distilled Water bath to rinse and tap holes to remove air 

bubbles. 
c. Use the air gun to dry the board. 

6. Begin plating 
a. loosen the screws on the bus bar and slide the substrate between the bar 

and the holder, tighten screws. 
b. Set current as calculated in step 4 by adjusting current knob.  If no current 

flows, check that the magnet on the lid has properly engaged the interlock. 
c. Let the board plate for the calculated time. 

 


