“HVMotorCirl + PFC” Kit How to Run Guide

Ver. 1.4 October 2010 C2000 Systems and Applications Team

This Guide explains the steps needed to run the HYMTRPFCKIT with the software supplied through
controlSUITE. The software is located at:

controlSUITE\developement _kits\HVMotorCtrl+PfcKit\

Following projects are currently available for the kit:
- Fixed point projects based on Piccolo (TMS320F2803x, using fixed v1.1 DMCLib)

HVACI_Sensorless: Sensorless Field Oriented Control of AC Induction Motor

HVACI_Sensored: Sensored Field Oriented Control of AC Induction Motor

HVPM_Sensorless: Sensorless Field Oriented Control of Permanent Magnet Motor

HVPM_Sensored: Sensored Field Oriented Control of Permanent Magnet Motor

HVBLDC_Sensorless: Sensorless Trapezoidal Control of BLDC Motors

HVBLDC_Sensored: Sensored Trapezoidal Control of BLDC Motors

HVACI_Scalar: Scalar control of AC Induction Motor

PFC2PhiLCLA_ACI : Sensorless Field Oriented Control of AC Induction motor with Power Factor
Correction using Control Law Accelerator(CLA)

- Floating point projects based on Delfino (TMS320F2833x, using v2.0 DMCLib)

e HVPM_Sensorless_2833x: Sensorless Field Oriented Control of Permanent Magnet Motor
e HVPM_Sensored_2833x: Sensored Field Oriented Control of Permanent Magnet Motor

The document assumes the user has read the Kit's Hardware Reference Guide and understood all
the safety measures that need to taken. The guide is found under

controlSUITE\developement _kits\HVMotorCtrl+PfcKit\~Docs\

WARNING

This EVM is meant to be operated in a lab environment only and is not considered by
' Tl to be a finished end-product fit for general consumer use.
L

This EVM must be used only by qualified engineers and technicians familiar with risks
associated with handling high voltage electrical and mechanical components,
systems and subsystems.

This equipment operates at voltages and currents that can result in electrical shock,
fire hazard and/or personal injury if not properly handled or applied. Equipment must be used with
necessary caution and appropriate safeguards must be employed to avoid personal injury or property
damage.

It is the user’s responsibility to confirm that the voltages are identified and understood, prior to
energizing the board and or simulation. When energized, the EVM or components connected to the EVM
should not be touched.

Isolation transformers must be used when connecting grounded equipment to the EVM.




Hardware Configuration (Motor Control)

To experiment with the digital motor control part of the kit the following hardware components are
needed:

= HVYMTRPFCKIT
TMS320F28035 or TMS320F28335 controlCARD:;

= Three-phase motor

= An incremental encoder or sprocket (optional);
PC with Code Composer Studio (CCSv4) installed;

Additional instruments such as oscilloscope, digital multi-meter, current sensing probe and function
generator. (Please read the Hardware Reference Guide [1] to determine the isolation needs for the
equipment).

= A high voltage DC power supply (isolating)

= 15V Power supply (supplied with the kit)

The experimental setup and connection are illustrated in the following section. Refer to the Hardware
Guide and HVDMC kit schematic file for detailed configuration of each component and connection of
the system in detail.

Note: Keep all the power supplies to zero unless directed to energize.

The HVDMC kit is separated into function-specific macro blocks. Following is the list of all the macros
with description of what each is responsible for on the board.

» [Main] - controlCARD connection, jumpers, communications (isoCAN), Instrumentation (DAC’s),
QEP and CAP connection and voltage translation.

= [M1] - AC power entry takes AC power from the wall/mains power supply and rectifies it. This can
then be used for input of the PFC stage or used to generate the DC bus for the inverter directly.

» [M2] - Auxiliary power supply, 400V to 5V and 15V module can generate 15V, 5V power for the
board from rectified AC power.

= [M3] - Isolated USB Emulation provides isolated JTAG connection to the controller and can be used
as isolated SCI when JTAG is not required.

= [M4] - Two-phase interleaved PFC stage can be used to increase efficiency of operation.

= [M5] - Three-phase inverter, to enable control of high voltage 3-phase motors.

= [M6] - DC power entry generates 15V, 5V and 3.3V for the board from DC power fed through the
DC-jack using the power supply shipped with the board.

To easily find a component, each component is referenced with their macro number in the brackets
followed by a dash and the reference number. For example, [M3]-J1 refers to the jumper J1 located in
the macro M3. [Main]-J1 refers to the jumper J1 located on the board, but out of the defined macro
blocks above.
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The Layout of HVDMC Board

= [Mainl - control CARD connection, jumper configurations, trip zones

= [M1] - AC power entry
= [M2] - Auxiliary power supply, 400V to 5V and 15V

= [M3] - Isolated UUSB Emulation

= [M4] - Two-phase interleaved PFC stage

= [M5] - Three-phase inverter



There are two main power domains on the HVDMC platform:

1) Controller Power Domain which provides the 15V, 5V and 3.3V for the microcontroller, the logic
and the sensing circuit present on the board. Power for this can be driven from two sources:

= Using the 15V DC Power supply, connecting to the DC Jack ([M6]-JP1) present on the DC
Power entry Macro. This is the recommended source for all the experiments.

= The Aux Power supply module [M2] present on the board can generates 15V and 5V DC from
rectified AC.

2) DC Inverter Bus Power is the high voltage line that provides the voltage to the inverter to
generate the 3 phase AC to control the motor. There are two options to provide this power to the
inverter:

= An external DC power supply can be used by connecting to Banana Jacks [BS5] and [BS6].
Using this power is recommended for all the experiments. (Max 350V)

= AC Main ([M1]-P1, 110V* or 220V AC Power supply), power can be rectified and converted to
DC power by the rectifier and the capacitor bank present on the board. For safety purpose, use
of a variac (variable AC transformer) and isolator is recommended when starting to use this
power source.

* Note that the 3-ph Induction motors are typically rated at 220V AC, so the 320 V DC-bus voltage is needed. Thus when using
110V AC power source to generate the DC Bus for the inverter the motor can run properly only at a certain speed and torque
range without saturating the PID regulators in the control loop. As an option, the user can run the PFC on HV DMC drive
platform as boost converter to increase the DC bus voltage level or directly connect a DC power supply.

Note that the ground planes of both the power domains are the same, hence proper
isolation requirements must be met before connecting any test equipment with the
board.

Motor Control Experiment HW Setup Instructions

For the purpose Motor Control Only Projects we would use the DC power entry macro to get the
voltages for the controller. For the DC Bus for the inverter either of the two options can be used.

1. Open the Lid of the HV Kit

2. Install the Jumpers [Main]-J6, J7 and J8, J9 for 3.3V, 5V and 15V power rails and JTAG reset
line, make sure that the jumpers [Main]-J3, J4 andJ5 are not populated.

3. Unpack the DIMM style control CARD and place it in the connector slot of [Main]-J1. Push
vertically down using even pressure from both ends of the card until the clips snap and lock. (to
remove the card simply spread open the retaining clip with thumbs)

4. Connect a USB cable to connector [M3]-JP1. This will enable isolated JTAG emulation to the
C2000 device. [M3]-LD1 should turn on. Make sure [M3]-J5 is not populated.

5. If a third party JTAG emulator is used, connect the JTAG header to [M3]-J2 and additionally [M3]-
J5 needs to be populated to put the onboard JTAG chip in reset.

6. Ensure that [M6]-SW1 is in the “Off” position. Connect 15V DC power supply to [M6]-JP1.

7.Turn on [M6]-SW1. Now [M6]-LD1 should turn on. Notice the control card LED would light up as
well indicating the control card is receiving power from the board.



8. Note that the motor should be connected to the [M5]-TB3 terminals after you finish with the first
incremental build step.
9. Note the DC Bus power should only be applied when instructed to do so. The two options to

get DC Bus power are discussed below,

» To use DC power supply, set the power supply output to zero and connect [Main]-BS5 and BS6
to DC power supply and ground respectively.

= To use AC Mains Power, Connect [Main]-BS1 and BS5 to each other using banana plug cord.
Now connect one end of the AC power cord to [Main]-P1.The other end need to be connected
to output of a variac. Make sure that the variac output is set to zero and it is connected to the
wall supply through an isolator.

Note for QSG, isolator is not required as measurement equipment is not connected to the board.

DC Power Supply (max. 350V)
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Using External DC power supply to generate DC-Bus for the inverter



2
2 @ 3 phase Inverter. .8 o
2 s+ PFC EWM &3
2
- m PFC-0ut S %\ e
® L1 tRel Hs1 I%IDID.; £ 2
— ]
o _ [ S
8
(@]
24
'—
5
uj! !%Euj q‘. &
%E;“E,c_e? = . “En 1 10 %—
S N ‘ S —
+ . (e
5|, EEEEE &
R £| s B
- "" ol SIRSSIRIRTED :
e F\‘:"’E . ]ﬂ: E.CGEE. E.JV:} ®1fb-1 DV!‘@E] .|—'. 'g & ACl
°® lorra —
5 Caution! ares 03 9| Motor
o 24l High Voltage - Eai: L A
AC < e oo B¥= 2 —
i 1 1 e o [l
Entry ° @ 3 e +@ele [R3] s e
[°% )
2 . e
II . o @ < é % s @ B]
. &g .mnp % T )
i N i g
o ° — H-1
o |i5 (0 i e Texas @ B ER e
== Instruments B el B
b RT1L AC Pur entry - 750M ®
© % e 011 @ = &
o O ~ N - ~
1 o 0—0 [ [
VAR1
AC-L ‘
ef ;%fw o L4 [ ] 2
E:] .D? ~ ;
° @ Tf o - DB1 s
@ (oo o EEeEINEIMET go

A

Using AC Power to generate DC Bus Power

AC Isolator Variac

=

L]

Wall Supply

[Main]-P1

WARNING: DC bus Capacitors would remain charged for a long time after the mains
supply is disconnected. Use caution!



Power Factor Correction plus Motor Control Experiment HW Setup
Instructions

For the purpose Power Factor Correction and Motor Control projects we would use the DC power
entry macro to get the voltages for the controller and use the AC Power Entry Block along with the
Power Factor Correction Block to generate the DC Bus for the operation of the motor.

10.
11.

12.

13.

14.

15.

16.

17.
18.

Open the Lid of the HV Kit

Install the Jumpers [Main]-J6, J7 and J8, J9 for 3.3V, 5V and 15V power rails and JTAG reset
line, make sure that the jumpers [Main]-J3, J4 andJ5 are not populated. Any jumper on [Main]-J2
can be removed.

Place the controlCARD in the connector [Main]-J1. Push vertically down using even pressure
from both ends of the card until the clips snap and lock. (to remove the card simply spread open
the retaining clip with thumbs)

Connect a USB cable to connector [M3]-JP1. This will enable isolated JTAG emulation to the
C2000 device through the XDS100 emulator present on the board. [M3]-LD1 should turn on.
Make sure [M3]-J5 is not populated.

If a third party JTAG emulator needs to be used, connect the JTAG header to [M3]-J2 and
additionally [M3]-J5 needs to be populated to put the onboard JTAG chip in reset.

Connect three banana cables as shown in the diagram below. (Please note the kit ships with only
a single banana cable, Please make sure that the other cables that you use are of appropriate
rating). The cable b/w [Main]-BS1 to [Main]-BS3 connects the rectified AC voltage to the PFC
stage input. The cable b/w [Main]-BS4 to [Main]-BS5 connects the Output PFC voltage to the DC
Bus for the Motor Inverter.

Connect one end of the AC Power Cord to the AC Connector present on the board. In the AC
power entry section. Do not connect the other end of the AC cord to the AC power source at
this stage. The AC Power is applied later, please refer to the project specific lab document for
details.

Ensure that [M6]-SW1 is in the “Off” position. Connect 15V DC power supply to [M6]-JP1.

Turn on [M6]-SW1. Now [M6]-LD1 should turn on. Notice the control card LED would light up as
well indicating the control card is receiving power from the board.



Banana Cable
[Main]-BS3 to
[Main]-BS1

Banana Cable [Main]-
BS4 to [Main]-BS5
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Software Setup for HVMotorCtrl+PFC Kit Projects

Installing Code Composer and controlSUITE

1.

If not already installed, please install Code Composer v4.x from the DVD included with the kit.

2. Go to http://www.ti.com/controlsuite and run the controlSUITE installer. Select to install the

“HVMotorCtrl+PFC” software and allow the installer to also download all automatically
checked software.

Setup Code Composer Studio to Work with the HVMotorCtrl+PFC kit

3.
4.

Open “Code Composer Studio v4”.

Once Code Composer Studio opens, the workspace launcher may appear that would ask to
select a workspace location,: (please note workspace is a location on the hard drive where
all the user settings for the IDE i.e. which projects are open, what configuration is selected
etc. are saved, this can be anywhere on the disk, the location mentioned below is just for

reference. Also note that if this is not your first-time running Code Composer this dialog may
not appear)

=  Click the “Browse...” button
= Create the path below by making new folders as necessary.

=  “C:\Documents and Settings\My Documents\ CCSv4_workspaces\
HVMotorCtrl+PFCKit_workspace”

= Uncheck the box that says “Use this as the default and do not ask again”.
»  Click “OK”

® Workspace Launcher

Select a workspace

Code Composer Studio stores your projects in a folder called a workspace.

Choose a workspace folder bo use For this session.

Workspace: | CHiDocuments and SettingsiMy DocumentsiCCavd_workspaces\HYMakorChr+-PRCKIE_workspace| -

oK ‘ [ Cancel

Figure 1: Workspace Launcher

Next we will configure Code Composer to know which MCU it will be connecting to. Click
“Target -> New Target Configuration...”. Name the new configuration xds100-f28035.ccxml

or any other name depending on the target device. Make sure that the “Use shared location”
checkbox is checked and then click Finish.



% New Target Configuration @

Target Configuration

Create a new Target Configuration File,

File: name: | %ds100_F2a035. coxml |

fA Use shared location

Location: | CiDocuments and Settingsiusernamepuser oS TargetConfigurations | ’Bmwse... ]

@ [ Finish l ’ Cancel

Figure 2: Creating a target configuration

6. This should open up a new tab as seen in Figure 2. Select and enter the options as shown:
= Connection — Texas Instruments XDS100v1 USB Emulator
» Device — TMS320F28035 (or TMS320F28335 if Delfino controlCARD is used)

= C(Click Save
= Close the xds100-f28035.ccxml tab ( or xds100-f28335.ccxml if Delfino controlCARD is
used)

General Setup

Advanced Setup
This section describes the general configuration about the target. |

Conneckion |Texas Instruments %D5100v1 USE Emulatar v | Target Configuration: lists the configuration options for the target,

Device | Fzanas

Save Configuration

[ Developer's Kit - Dual Mator Control and PFC (F28035)
[] peveloper's Kit - Mokar Control and PRC (F28035)

[] Experimenter's Kit - Piccola F28035

TM5320F26035

Mote: Support for more devices may be available from the update manager.,

Figure 3: Configuring a new target



7. Assuming this is your first time using Code Composer, the configuration is now set as the
default target configuration for Code Composer. Please check this by going to“View->Target
Configurations”. In the “User Defined” section, right-click on the xds100-F28035.ccxml file
and select “Set as Default”. This tab also allows you to reuse existing target configurations
and link them to specific projects.

8. Add all the motor control projects into your current workspace by clicking “Project->Import
Existing CCS/CCE Eclipse Project”.

=  Select the root directory of the HVMotorCtrl+PFC. This will be:
“C:\TN\controlSUITE\development_kits\HVMotorCtrl+PFC\’

® Im port

Import Projects

Select a directory to search For existing Eclipse projects,

() select root directory: CHititcontrolSUITE N development _kitsiHy B[nwse
() Select archive File:

Projects:

H¥ACI_Sensored
HWACT_Sensarless

HWPM_Sensared
HYPM_Sensorless

I:l Copy projects into workspace

@ [ Finish ] [ Cancel ]

Figure 4: Adding all HVMotorCtrl+PFC kit projects to your workspace

= Click Finish, this would copy all the projects relevant for the kit into the workspace. If you
want only a particular project to be copied uncheck the box next to the other project
names.

Configuring a Project

9. Expand the file structure of the project you would like to run from the C/C++ Projects tab.
Right-click on this project's name and select “Set as Active Project”.

10. Assuming this is your first time using Code Composer, the xds100-F28035 should have been
set as the default target configuration. Do verify this by viewing the xds100-f28035.ccxml file
in the expanded project structure and a [Active/Default] written next to it. By going to “View->
Target Configurations” you may edit existing target configurations or change the default or
active configuration. You can also link a target configuration to a project in the workspace by
right clicking on the Target configuration name and selecting Link to Project.

11. Each project can be configured to create code and run in either flash or RAM. You may select
either of the two, however for lab experiments we will use RAM configuration most of the time and



move to the FLASH configuration for production. As shown in Figure 4, right-click on an individual
project and select Active Build Configuration-> F2803x_RAM (or F2833x_RAM) configuration.

[ el Target Configurations =0

#- =5 HYACT_Sensared

= bc HYACI_Sensorless [Active - F2803x_RAM
ey 4

= Includes
= ~Dacs G0 Into
dlog4ch-HYACT_Sensorless.h
HYACI_Sensorless.h Open in Mew Window

HvACI_Sensorless-3ettings.h
DLOG4CHC. asm

[$4 DSP2803x_CodestartEranch.asm Rebuild Tndex
| DSP2803x_GlobalvariableDefs.c e EE] Gl 1 F250%¢ FLASH
D5P2803%_usDelay,asm = ;
lg| HyaCI_Sensorless.c

|g| HyaCI_Sensorless-DevInit_F28035x.C
18] czooo_tnitseript. js

iy DSP2E03%_Headers_nonBIOS,cmd
Ef F28035_FLASH_HYACI_Sensorless.CMD [Exd 12 Copy
9 Fz8035_RAM_HvACI_Sensorless . CMD

% IQmath.-IiI.J ¥ CDelete
= Macroas.inl

% xds100-F28035, coxml [Active/Default] Mave...
R HYPM_Sensored Renams
) =5 HYPM_Sensarless 4 Refresh

1T Set as Active Project

Convert Ta..,

3 O O < S R

Clean Project
Build Project
Rebuild Project

Close Project

Debug As 4
Team L4
Compare With 4
Restore from Local History. ..

Link, Files to Project. ..
Add Files to Project. ..

Open Target Configuration
Build Properties. ..
Debug Properties...

Propetties
T

Figure 5: Selecting the F2803x_RAM configuration

Build and Load the Project

12.

13.

14.

The TI motor control software is provided with incremental builds where different components
/ macro blocks of the system are pieced together one by one to form the entire system. This
helps in step by step debug and understanding of the system. From the C/C++ Project tab
open the file [Project-Name]-Settings.h and make sure that BUILDLEVEL is set to LEVEL1
and save this file. After we test build 1, this variable will need to be redefined to move on to
build 2, and so on until all builds are complete.

Open and inspect [Project-Name] -Devlnit_F2803x.c (or Devlnit_F2803x.c) by double clicking
on the filename in the project window. Confirm that GPIO00 to GPIO05 are configured to be
PWM outputs.

Open the [Project-Name].c file and go to the function MainISR(). Locate the following piece of
code in incremental build 1 and confirm that the Datalog buffers are pointing to the right
variables. These Datalog buffers are large arrays that contain value-triggered data that can
then be displayed to a graph. Note that in other incremental builds different variables may be
put into this buffer to be graphed. Following is an example where the datalog are pointed to
the space vector generator module.
DlogChl = (intlé6
DlogCh2 (intl6
DlogCh3 = (intl6
DlogCh4 = (intlé6

_IQtoIQl5(svgen_dgl.Ta);
_IQtoIQl5(svgen_dgl.Tb);
_IQtoIQl5(svgen_dgl.Tc);
_IQtoIQl5(svgen_dgl.Ta-svgen_dqgl.Tb);

—_ — — ~—



15.

16.

17.

18.

19.

Now Right Click on the Project Name and click on “Rebuild Project” and watch the Console
window. Any errors in the project will be displayed in the Console window.

On successful completion of the build click the ¥ “Debug” button, located in the top-left side
of the screen. The IDE will now automatically connect to the target, load the output file into
the device and change to the Debug perspective.

Click “Tools->Debugger Options->Generic Debugger Options”. You can enable the debugger
to reset the processor each time it reloads program by checking “Reset the target on program
load or restart” and click “Remember My Settings” to make this setting permanent.

-
Now click on the “Enable silicon real-time mode” button 1 and “Enable polite real-time

mode” button @. This will allow the user to edit and view variables in real-time. Do not reset
the CPU without disabling these realtime options!

A message box may appear. If so, select YES to enable debug events. This will set bit 1
(DGBM bit) of status register 1 (ST1) to a “0”. The DGBM is the debug enable mask bit.
When the DGBM bit is set to “0”, memory and register values can be passed to the host
processor for updating the debugger windows.



Setup Watch Window & Graphs

Click: View - Watch on the menu bar to open a watch window to view the variables being used in
the project. Add variables to the watch window as shown below. By right-clicking on the variable it is
possible to change the number format of the variable. Refer to the project specific document to know
what variables need to be added to the watch window. You can select the appropriate Q format for
the variable you want to watch. Figure below shows a typical watch window.
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Figure 6: Configuring the Watch Window for (a) fixed point devices (b) floating point devices



20. Click on the Continuous Refresh button '1‘3& in the watch window. This enables the window to

21.

run with real-time mode. By clicking the down arrow in this watch window, you may select
“Customize Continuous Refresh Interval” and edit the refresh rate of the watch window. Note
that choosing too fast an interval may affect performance.

The datalog buffers point to different system variables depending on the build level. They
provide a means to visually inspect the variables and judge system performance. Open and
setup time graph windows to plot the data log buffers as shown below. Alternatively, the user
can import graph configurations files in the project folder; however, these files are not
supported by all CCS4 versions. In order to import them, Click: Tools -> Graph ->
DualTime... and select import and browse to the following location
C:ATNControlSUITE\developement_kits\HVMotorCitrl+PfcKit\<project directory> and select
Graph1.graphProp, the Graph Properties window should now look like the figure7. Hit OK,
this should add the Graphs to your debug perspective. Click on Continuous Refresh button

on the top left corner of the graph tab.

Note: If a second graph window is used, you could import Graph2.prop, the start Addresses
for this should be DLOG_4CH_buff3 and DLOG_4CH_buff4.

Note: The default dlog.prescaler is set to 5 which will allow the dlog function to only log one
out of every five samples.
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Q_value 15

Sampling Rate HZ 1

Skart Address & DLOG_4CH_buffi

Start Address B DLOG_4TH_buff2
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Ciata Plot Style Line

Display Data Size 200
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Figure 7. Graph window settings



Run the Code

22. Run the code by pressing Run Button U in the Debug Tab.

23. The project should now run, and the values in the graphs and watch window should keep on
updating. Below are some screen captures of typical CCS perspective while using this
project, You may want to resize the windows according to your preference.

24. Once complete, reset the processor “# (Target->Reset->Reset CPU) and then terminate the

debug session by clicking ® (Target->Terminate All). This will halt the program and
disconnect Code Composer from the MCU.
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Next Steps

25.

26.

27.

It is not necessary to terminate the debug session each time the user changes or runs the
code again. Instead the following procedure can be followed. After rebuilding the project,

(Target->Reset->Reset CPU) - (Target->Reset->Restart ) ‘tig"?’, and enable realtime options.
Once complete, disable realtime options, and reset CPU. Terminate the project if the target
device or the configuration is changed (Ram to Flash or Flash to Ram), and before shutting
down CCS.

Customize the project to meet your motor. Change the motor parameters which can be found
in [motorproject].h. Feel free to also change the PWM switching frequency (ISR frequency)
and the base Q-value to balance accuracy and CPU bandwidth.

Now the user can open the lab manual found in :
C:\TNhcontrolSUITE\development_kits\HVMotorCtrl+PfcKit_v1.2\HVxxx_Sensorxx\~Docs and
start experiments.



