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Remote Sensing Flood Analysis Lesson Using MultiSpec Online 
 

By Larry Biehl 
Systems Manager, Purdue Terrestrial Observatory 

(biehl@purdue.edu) 
 

v Objective 
The objective of these exercises is to analyze a flood event that occurred in southern Indiana and 
Illinois in June of 2008. You will use a freeware tool on mygeohub.org titled MultiSpec to view 
a portion of the area that was flooded and determine the area that the flood covered. 

Background.  MultiSpec is a multispectral image data analysis software application that was 
developed at Purdue University. It is intended to provide a fast, easy-to-use means for analysis of 
image data, such as that from satellites like Landsat, SPOT, MODIS and from imaging sensors 
on aircraft and drone platforms. The primary purpose for the software package was to make new, 
otherwise complex analysis tools available to the general Earth science community. It has also 
found use in displaying and analyzing many other types of non-space related digital imagery, 
such as medical image data and in K-12 and university level educational activities. 
 

MultiSpec was implemented for both the Apple Macintosh and Microsoft Windows operating 
systems (OS).  More recently an online version has been made available. Although copyrighted, 
MultiSpec with its documentation is distributed without charge. The Macintosh and Windows 
versions and documentation on its use are available from the World Wide Web at: 
https://engineering.purdue.edu/~biehl/MultiSpec/. 
 

MultiSpec is copyrighted (1991-2016) by Purdue Research Foundation, West Lafayette, Indiana. 

Exercise List 
  1:  Display and Inspect Image Data 
  2:  Determine Area Covered by Water 
 

  3:  View Classification Results (Optional) 
  4:  Other Ways to View the Image (Optional) 
  5:  What are Affects of Flood One Month Later (Optional)  
 
v Other Remarks: See the MultiSpec Introduction at the MultiSpec web site for more 
information and other tutorials. 
Or contact Larry Biehl at biehl@purdue.edu with questions. 

 
v References 
Based on USGS Education River Flooding Activity (eros.usgs.gov/educational-activities) 
MultiSpec Introduction (https://engineering.purdue.edu/~biehl/MultiSpec/documentation.html) 
MultiSpec Tutorials (https://engineering.purdue.edu/~biehl/MultiSpec/tutorials.html) 
MultiSpec Online (https://mygeohub.org/tools/multispec) 
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v Exercise 1: Display and Inspection of Image Data 
Requirements:  Online MultiSpec Tool and images titled  
 - 2007_06_09_Vincennes.tif 
 - 2008_06_11_Vincennes.tif 
In this exercise, you will display Landsat 5 images for an area in Illinois and Indiana that 
includes the cities of Vincennes, IN and Lawrenceville, IL. You will view the data in several 
ways using MultiSpec Online. 

1.1 Start MultiSpec Online in a web browser (Firefox or Chrome on Windows OS or Safari, 
Firefox or Chrome on MacOS) using https://mygeohub.org/tools/multispec as the url. 

1.2 This page gives a very brief description of MultiSpec and links to several tutorials 
describing how to use some of the features in MultiSpec. Note that these tutorials are based 
around the desktop versions of MultiSpec and therefore may contain slightly different 
screenshots than one sees with the Online version. 

 - Launch MultiSpec using the ‘Launch Tool’ button in the upper right of this page. 
 - You will be requested to log in if you are not already logged in.  

 - The browser screen will contain a window similar to the following: 

          
 - You may stretch the browser window to fill the monitor space and then expand the 

MultiSpec tool window to fill the browser space. 
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1.3 From the File menu choose Open Image....  A dialog box will appear to allow one to select 
the data file one wishes to use. 

       
1.4 Open the ‘total_camp’ folder and then select ‘2008_06_11_Vincennes.tif’ and Open, or 

simply double-click on ‘2008_06_11_Vincennes.tif’. Be sure to select the ‘.tif’ file. 
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‘2008_06_11_Vincennes.tif’ is a portion (871 lines x 1172 columns of pixels) of a 7-
channel Landsat 5 satellite image collected on June 11, 2008. Next a dialog box will appear 
to allow one to choose among various options for displaying the image. 

           
 

 Note that by default, the area designated for display is the whole scene and the 3-Channel 
Color Display Type is selected. Set the Red screen color to be derived from band 3, Green 
from band 2 and Blue from band 1. These particular choices will cause the image on the 
screen to be similar to a natural color image.  

 
 Select OK. 
 
1.4 This step may not occur for all situations.  If the data histogram has not previously been 

calculated and stored (in a .sta file), another dialog box will be presented allowing the 
choice of regions to be histogrammed, so that the channel data values can be properly 
assigned to screen colors. The default options built into this dialog box are satisfactory, so 

 

 Select OK to begin the histogramming. 
 

After the histograms of all of the channels have been computed, the information will be 
saved to a file named “2008_06_11_Vincennes.sta” so that they will not have to be re-
computed when needed again. 
[Note that if a .sta file already exists with the default name, a dialog box will be presented 
allowing you to overwrite the existing .sta file or save to a different location.] 
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1.5 The image of the data will now appear something like below.  

        
 Notice that just above the image window in the toolbar there is a small magnifying glass 

with a ‘+’ to allow one to zoom into the image and another magnifying glass with a ‘-‘ to 
zoom out of the image. Just to the left of the image zooming buttons is another button that 
shows X1 in grayed form. This button allows one to go to x1 magnification directly. The 
current zoom magnification is displayed along the bottom of the MultiSpec application 
window in the box labeled “Zoom=”. 
Some other options are to hold the ‘Ctrl’ key down while zooming to change the zoom step 
factor to 0.1 instead of 1. In other words, the zoom factor will change from 1.0 to 1.1 to 1.2 
etc. instead of 1, 2, 3, etc. 

One can make a selection within the image by left click-hold in the image window, drag to 
select a rectangle, and then releasing the left mouse button. If a selected area exists in the 
image, any zooming will be centered on the selected area if possible. Clear selection using 
the “Delete->” key. 

Can you find the cities in this image? Lawrenceville, IL is in the left portion of the 
image and Vincennes, IN is in the south center of the image east of the Wabash River. 
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1.6 One can try different channel combination to go with the red, green and blue screen colors 
to see if different features in the image are enhanced. From the Processor menu, select 
Display Image… to bring up the display dialog box and select channel 4 for the red screen 
color, channel 3 for the green screen color and channel 2 for the blue screen color. This set 
of choices will cause the screen image to represent what is called a color infrared image. 
Vegetation is red in this channel combination. 

 Also try a combination with channels 5, 4, and 3. Try other combinations.  

 Which combination brings out the water in the image the best for you? 
 
1.7 Open an image window for a Landsat 5 scene of the same area acquired a year earlier (June 

9, 2007). Use the File->Open Image... menu item.  

  - Select the total_camp folder and then  
    - Open “2007_06_09_Vincennes.tif”.  

 Compare the two images using the same channel combinations for each.  

 What differences do you see in the 2007 and 2008 images? 
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1.8 Coordinate View (optional). The “coordinate view” is displayed along the top of the 
image to present the cursor (mouse) location and selected areas in the image. (One can use 
the View->Coordinate View menu item to hide and show this bar.) 

 
 

 If map coordinate information exists for the image, one can display the coordinates as map 
units. Use the popup menu on the left side of the coordinate view to select the map units.  
The area of the selection can be displayed as the number of pixels or in units of acres, 
hectares, etc using the popup button to the left of “Scale”.  The scale of the image will also 
be displayed. 

 
 What is the Latitude-Longitude for Vincennes, IN? 
 
 
 
 What is the Latitude-Longitude for Lawrenceville, IL? 
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v  Exercise 2: Determine the Area of Water in the Image 
Requirements:  MultiSpec Tool and image titled “2008_06_11_Vincennes.tif”. 
This exercise will use what is called a supervised classification approach to determine the area of 
coverage of the water in the image. You will select areas in the image to represent water, 
vegetation and bare land to be used to train a “classifier model” which is then used to assign all 
pixels in the image into water, vegetation and bare land categories. 

Open the 2008_06_11_Vincennes.tif image if it is not already displayed in a multispectral image 
window following the guidelines given in exercise 1. You may close or minimize the 
2007_06_09_Vincennes.tif image if one exists or at least make sure the 2008 image is the one on 
top (active). 

2.1. Select Training Areas  
2.1.1 You will now select training 

areas to represent water, 
vegetation and bare land.  

 From the Processor menu 
select Statistics and click OK 
in the Set Project Options 
dialog box since all of the 
default values are satisfactory. 
A new window labeled Project 
will appear to the right of the 
screen that will be used in a 
moment. This Project window 
is linked to the active image 
window 
(2008_06_11_Vincennes.tif). This window is the base image for the project. A Project 
window has only one base image.  
To select training fields for each class, you must simply "drag" a rectangular area on the 
image (or, with polygon option selected, click on the corners of the desired polygon), and 
then "Add that field to the list." Thus, 

Drag from the upper left corner to the 
lower right corner of the Water training 
field in the image window. If upon 
inspection, one does not like the exact 
boundaries resulting, one may 
immediately repeat the process.  
Caution: A mistake that is often made is 
to select training areas very near edges 
of a field or homogeneous area. One 
should stay away from the edges by a 
couple of pixels to reduce the chance of 
edge affects. 



Determine Area Covered by Water  Exercise 2 

AmericaView EOD 2016 page 9 of 16 

 Note, in the Project dialog box, that the coordinates (row and column numbers) of the 
upper left corner and the lower right corner of the selected area appear there. Now... 

2.1.2 Click on the Add to list button. A dialog box will 
appear to allow one to name the class and give 
the field a special designation, as desired. Thus, 
Type Water into the Class Name box and then 
click OK.   

2.1.3 Since there is to be only one training field for 
this class, we are ready to select the area for the 
second training class. Thus next, 

 Drag across the second training field in the 
Image Window shown below for Vegetation 
(greenish color in the image below). 

 Click on the Add to list button in the Project 
window and name the class Vegetation. 

 Select the training area for Bare Land (pinkish color in the image below). 

 If one selects the  >Classes button in the Project window, one will get the Class List mode 
of the Project window as illustrated in the image below. 
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2.2. Use Training Areas to Determine Area of Water (Classification) 
2.2.1 You will now use these training areas to determine the area of water in the image. This 

procedure is called classification ... specifically supervised classification. 
2.2.2 From the Processor menu select Classify…. In the Set Classification Specifications dialog 

box that appears Click on the √ near Training under Classify to de-select it. We only need 
the information for the “Image selection”. Use entire area for ‘Area to Classify’. 

       
Note that under Write classification results to: Select the Disk File button causing a disk 
file version of the results to be written. This will be used for the exercise 4. 

Since the other default options are satisfactory, Click on OK, then Update to the "Update 
Project Statistics" dialog box, and also click OK to write the classification results to the 
default location for the output disk file. The classification will then begin and complete in a 
few seconds. 

2.2.3 From the Window menu select Text Output, to bring the text window forward and make it 
active, since it contains the classification results. The “CLASS DISTRIBUTION FOR 
SELECTED AREA” table tabulates how the pixels in the image were assigned to each of 
the three classes that you defined. The table also includes the total area for that class.  

 What is the area for “Water” in your classification analysis? 
 
 The default units for the area is “Hectares”. You can get the listing using a different unit by 

selecting the Options->Area Units-> menu item. Make a different selection (such as acres) 
and redo the Classification process (Processor->Classify… menu item) to get a table with 
those units. (You can turn the Disk File option off for this run if you wish.) 
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2.2.4 How does the area for Water in the June 2008 flood image compare with the area of water 
in the June 2007 image?  

 What are the steps you would use to determine that information? 
 The process to answer the above question is to: 

  - First close the Project window (One can save it to use later if one wishes). 
  - Bring the June 2007 image to the top (or reopen this image). 

  - Follow the steps in 2.1 and 2.2 (through 2.2.3) using the 2007 image as the base image   
for the Project. 

 

What is the area covered by the flood in the June 2008 image (not the total 
area of water)? 
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vExercise 3: View Classification Results (Optional): 
 
 If you selected the Disk File open under Write classification results to: in section 2.2.2, 

one can view the classification map that was generated from that operation. 

3.1 Now open the classified image named “2008_06_11_Vincennes_cl.tif”. Select the File-
>Open Image... menu item. Select the “Recently Used” button in the upper left of the open 
image dialog box and then “2008_06_11_Vincennes_cl.tif”. The classification map should 
appear similar to the image below. The classes may be in a different order. This is a 
Thematic type image ... the colors represent the “themes” in the image. 

 
 

3.2 After displaying the classified image “2008_06_11_Vincennes_cl.tif”, from the Project 
menu, select Add as Associated Image to cause the training field outlines to be drawn on 
the image  
There are some things that one can do to evaluate the results. You can select one of the 
classes in the legend to the left of the image. If you then hold the shift key down, the color 
for that class will change to white on the legend and the image. If one lets the shift key up 
the colors will change from white back to the original color for the class. 
If you holds the ctrl key down and then push the shift key down, the colors of the other 
classes change to white.  
These procedures are helpful in understanding the extent of the classes in the image and to 
determine where classification errors may be. One may need to change training fields or 
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add other classes if there appears to be confusion between the categories that you wish to 
identify. 

One can also change the class color by double clicking on the color chip. 
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vExercise 4: Other Ways to View the Image (Optional):   
 There are other ways to view these Landsat images (or any other remote sensing type 

images). One of these is what is called single channel gray scale images. Another is a side -
by - side view of the individual channels. 

4.1 For either of 2007_06_09_Vincennes.tif or 2008_06_11_Vincennes.tif, use the Processor 
menu, select Display Image… to bring up the display dialog box. Then select Display Type 
“1-Channel Grayscale”, and select OK to display channel 1 as a gray scale image. You can 
use right and left arrow keys to go to the next or previous channel (respectively). Channel 4 
for 2008_06_11_Vincennes.tif  will look similar to the image below.  

       
 Channel 4 is the near infrared channel. Note that water does not reflect much sunlight in the 

near infrared portion of the spectrum. Vegetation on the other hand is bright in this 
channel; it reflects a lot of sunlight. 

 What appears to be different in channel 7? 
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4.2 Next you can view a side-by-side channel display for data quality inspection. From the 

Processor menu, select Display Image… to bring up the display dialog box. Then select 
Display Type “Side-by-Side Channels”, and select OK to display all seven channels in the 
image side by side. 

 

 
 

 

 The above image window will be displayed (after zooming out) which shows all seven 
channels displayed side-by-side. Note the change in the tone near the center of the image as 
one goes from the visible channels on the left to the infrared channels on the right. 

 This view is a quick way to compare the channels to verify that none of the channels are 
noisy. One can also make a selection around a prominent feature like a field to verify that 
this selection is at the same location in each channel. 

 
 



Exercise 4  View Classification Results 

AmericaView EOD 2016 page 16 of 16 

vExercise 5: Compare Flood and After Flood (Optional): 
Requirements:  Online MultiSpec Tool and images titled  
 - 2008_06_11_Vincennes.tif 
 - 2008_07_13_Vincennes.tif 
In this exercise, you will compare images of the area during the flood and one month after the 
flood.  

Open both the June and July 2008 images and position them side by side. 
 

Do you still see affects of the flood in the image collected one month later? 
 


