
Creating a new Part Type using the PCB & 

CAE Decal Wizards V9.1 

 

 
Note: This tutorial is modified from the original tutorial to bring it up to date for version 

9.1 and to expand on some additional features that may be useful for  

ECE477 senior design students. The original tutorials are located at: 

 

http://www.people.vcu.edu/~rhklenke/tutorials/PADS/PADS_Tutorial_3.3V_

Reg/SimpleReg.html 
http://www.people.vcu.edu/~rhklenke/tutorials/PADS/PADS_Tutorial_New_Part/NewPart

Type.html 

 

A part is an object that can be represented in a schematic and as a physical item on a printed 

circuit board, or PCB. In order to be used in a design the part must be set up for use in the 

schematic and layout portions of the PADS application. Three items are represented by the part:  

1. CAE Decal, which is used as the schematic symbol; 

2. PCB Decal, which represents the physical part that will be placed on the circuit board; 

3. Electrical data, which is specific information for that part such as resistor and capacitor 

values, power ratings, manufacturer and other information. 

 

Many parts may use the same CAE and PCB decal symbols; the symbols are contained in the 

libraries that come with PADS. Those items not included in the libraries must be manually 

generated by the schematic Part Editor and the layout PCB Decal Editor. Two methods 

demonstrated here are the use of the PCB decal wizard and modification of an existing footprint.  

 

What you will learn: 

 Creating and Managing User Libraries 

 Creating a PCB Decal 

 Creating a CAE Decal  

 Creating a Complete Part 

Section 1 -  Create a schematic symbol using the Part Editor & CAE Decal Wizard. 
 

We will now create a schematic symbol for the National Semiconductor LM2675M-5 

voltage regulator chip. 

 

1.1    Open PADS Logic.  Select  Start > Programs > ECE Software 

> Mentor Graphics SDD > PADS 9.1 > Design Entry > 

http://www.people.vcu.edu/~rhklenke/tutorials/PADS/PADS_Tutorial_3.3V_Reg/SimpleReg.html
http://www.people.vcu.edu/~rhklenke/tutorials/PADS/PADS_Tutorial_3.3V_Reg/SimpleReg.html
http://www.people.vcu.edu/~rhklenke/tutorials/PADS/PADS_Tutorial_New_Part/NewPartType.html
http://www.people.vcu.edu/~rhklenke/tutorials/PADS/PADS_Tutorial_New_Part/NewPartType.html


PADS Logic.  The PADS Logic welcome screen should appear. 

 
 

 

1.2   Create a user library.  Select File > Library... 

 

 
 

Then press the Create New Lib... button. Navigate to your N:\(Pads Library) 

and create a parts library, for this case tutorial.pt9. Click on the Manage Lib. List… 

and verify that your newly created parts file is located in the Library drop-down list. 

Press OK and then close the library manager. 

 

We will be creating a schematic part for the National Semiconductor LM2675M-5 switch 

mode voltage regulator chip.  The relevant datasheet can be found here.  (Page 24 of the 

data sheet contains information on the part's physical dimensions). 

 

1.3   Open the Part Editor.  Select Tools > Part Editor.  The PADS Logic 

window should now look similar to the image below. 

 

http://www.national.com/ds.cgi/LM/LM2675.pdf


 
 

1.4   Select File > New. On the Select type of editing item dialog, choose Part 

Type and press OK. 

 

 
 

1.5 Click the Edit Electrical icon,  , and the Part Information for Part window 

pops up as shown below. 

 

 
 

 

1.6 To specify the schematic decal to be created select the Gates tab. Click Add, double-

click in the CAE Decal 1 field, type LM2675 and press Enter.  Then press the OK button.  

 

 



 
 

 

1.7   To open the CAE Decal Editor press the Edit Graphics  button on the toolbar to 

open the CAE Decal Editor.  The Select Gate Decal dialog will pop up. 

 

 
 

Press OK to continue.  PADS Logic will display a warning stating that the selected decal 

doesn't exist and will be created.  Press OK. 

 

 
 

The CAE Decal Editor should now appear. Press the Decal Editing Toolbar icon,  , to 

bring up the toolbar as shown below. 

 

 
 

Your display now looks like that below. 

 



 
 

1.8   To start the CAE Decal Wizard, press the CAE Decal Wizard button,  , on the 

Decal Editing toolbar to launch the Decal Wizard. 

 

 
 

1.9   Make the following changes so that your Decal Wizard is filled in as shown below: 

In the Pin Spacing area, type 300 in the Horizontal box and 200 in the Vertical box. 

In the Left Pins area and Upper Pins area, set the Pin Count to 1. 

In the Right Pins area and Lower Pins area, set the Pin Count to 2. 

 

 
 

When the specified values have been entered, press OK.  The CAE Decal window should 

now look similar to the one below. 

 

 

Tool Note: You may wish to zoom in 

and out on the decal while making 

changes to the pins.  Several methods 

may be used to zoom: 

1. To enter zoom mode, press Ctrl + 

W.  Use the left mouse button to zoom 

in and the right mouse button to zoom 



 
 

 

1.10   Name and Number the pins.  Right-click in an empty area and select the Select 

Terminals menu item.  Double-click on the leftmost pin.  The Terminal properties 

dialog will open. 

 

 
 

Type 7 in the Number box, Vin in the Name box, and select Power in the Type: drop-

down box.  Then press OK.  Repeat this process for the remaining 5 pins.  Proceeding 

clockwise, name and number the pins as follows: 

Number: 4, Name: FB  Type: Undefined 

Number: 1, Name: CB Type: Undefined 

Number: 8, Name: VSW Type: Undefined 

Number: 6, Name: GND, Type: Ground 

Number: 5, Name: ON/\OFF 

Note: For pin 5, the name will appear as .  The back-slash is used to specify a 

logical not and will make a bar appear over the word immediately following it. 

 

When you are finished naming and numbering the pins, the CAE Decal Editor should 

look similar to the image below.  

 

The outline size may be modified by selecting the Modify 2D Line icon, , and 

adjusting the box as needed, and moving the pins to create a more readable symbol. The 

pins are not connected to the box outline so you will need to adjust the box size then drag 

the pins to the periphery. Press Esc when you are done re-sizing the outline then click 



and drag the terminals so that the ends lie on the outline. 

 

 
 

1.11   To save the schematic symbol select File > Return to Part.  When 

prompted to keep changes, press Yes.  The Part Editor should now look like this: 

 

 

Click on the Edit Electrical icon,  , and select the Pins tab as shown below. 

 



 
 

You will note from the data sheet that the device actually has eight pins but that pins 2 

and 3 are unused. Click the Add Pin button to add pins 2 and 3. Enter 2 and 3 under the 

Number column. Click on both in the Pin Group column and change the attribute to 

Unused Pin as shown below. 

 

 
 

Click OK. 

Minimize PADS Logic. At this point you will either create a PCB footprint using the 

PCB Decal Wizard as detailed below in Section 2, or create a custom footprint as 

shown in Section 3. 

 

Section 2 -  Create a PCB footprint using the PCB Decal Wizard 

 

Start PADS Layout.  Select  Start > Programs > ECE Software > 

Mentor Graphics SDD > PADS 9.1 > Design Layout and 

Routing > PADS Layout.  The PADS Layout welcome screen should 



appear. 

 

 
 

 

     
 

We will now create a PCB footprint, also called a PCB decal in PADS, for the National 

Semiconductor LM2675M-5 switch mode voltage regulator chip.  The relevant 

datasheet can be found here.  (Page 24 contains information on the part's physical 

dimensions). 

 

2.1 To open the PCB Decal Editor in PADS Layout, select Tools > PCB Decal 

Editor.  The PADS Layout window should now look similar to the image below. 

 

 
 

2.2   Start the PCB Decal Wizard.  Enable the Drafting Toolbar by pressing the  

button.  From the Drafting Toolbar press the Wizard button: .  The default Decal 

Wizards window will now appear. 

 

http://www.national.com/ds.cgi/LM/LM2675.pdf


 
 

2.3   First, update the Units parameter in the bottom left corner of the window to Inches 

to match the datasheet; we can choose between Mils, Inches or Millimeters. A Mil is 

.001 inch and is a convenient dimension for layout when using inches as the 

measurement standard.  In this case we will use inches, so use the parameter within the 

parentheses. 

 

 

 

 

 

 

 

 

 

 

2.4 In the Decal Calculator box, change the Package type to SOIC which stands for 

Small Outline Integrated Circuit. This is an illustration of the type of device which 

would be used with the footprint you are creating. Note the picture and the 

abbreviations as they relate to the dimension table. 

 

We will be creating a decal for a surface mount device, abbreviated SMD, 8-pin Small 

Outline Package. Experiment with the parameters and note how the Preview changes. 

For our device, update the device parameters as follows:  

 

CAUTION!!  Data sheets must be carefully examined to make sure they are being correctly interpreted. Note that at the top of the data sheet the 

dimensions are indicated as inches (millimeters), implying that the measurements shown are in inches outside and millimeters inside the parentheses. 

However, if you look under the pictures you see a note which states: 

CONTROLLING DIMENSION IS MILLIMETER 

VALUES IN [] ARE INCHES 

Be careful which parameter you use, and that you are consistent in use.  

 



Device type – SMD 

Orientation – Vertical 

Height – 0.05 

Origin – Pin 1 

Pin count – 8 

Numbering direction – CCW 

Width – 0.02 

Pin pitch(P) – 0.05  (note: P refers to the picture in the Decal calculator window) 

Row pitch – Center to center -  0.236 (note: this should be based on the lead span, A2 

in the Decal Calculator package, and should be approximately (A2 + 0.05 inches) to 

allow for solderability. If you designate the Center to Center to be the lead span this 

should automatically allow the required pad exposure.)  

Pin 1 shape – Rectangle (note: this pin differentiation aids in device orientation. ) 

Pin shape - Oval 

Rectangular pins – 90 degrees 

 

Leave Placement outline and Mask over(under)size as default values.  

 

The Decal Wizard window should resemble the one below. 

 

 



 

2.5 Press OK.  You will now return to the PCB Decal Editor which should look like the 

image below. 

 

 
 

2.6   Save the PCB footprint to your user library.  Select  File > Save Decal.  In 

the Save PCB Decal to Library dialog, select N:\(Pads Library) for the library 

and type LM2675 in the Name of PCB Decal field. 

 

 
 

Press OK.  If it asks if you want to create a new Part Type, click No. 

 

To exit the PCB Decal Editor, select  File > Exit Decal Editor to return to 

PADS Layout. Select  File > Exit to close PADS Layout. 

Return to PADS Logic and click on the Edit Electrical icon,  , click the PCB Decals 

tab and select the footprint you just created by highlighting it in the Unassigned Decals 

box and clicking the Assign button. 

Click Check Part to make sure no errors or warnings are found. If there are none then 

click OK to close the Edit Electrical window. Select File > Save to save the 



part. Be sure to fill in the Name of Part with the part 

name as shown below. 

 

 
 

Select File > Exit Part Editor to return to the schematic 

window. 

 

You can now use the LM2675 part type in your PADS Logic and PADS Layout designs. 

 

Section 3 - Custom footprint creation 

Although the PADS libraries contain a large number of footprints, there may be instances 

when you need to create a unique footprint. First, create the schematic representation as outlined 

in Part 1. 

3.1 Open PADS Layout - Start > Programs > ECE Software > 

Mentor Graphics SDD > PADS 9.1 > Design Layout 

and Routing > PADS Layout. 

 

3.2 Open the Library Manger – File > Library and either create a library or make 

sure your desired library is accessible, then close the Library Manager window.  
 

3.3 Open the PCB Decal Editor – Tools > PCB Decal Editor. The window will open as 

shown below. 

 



 
 

For this design we will use the footprint for a Microchip MCP73811 which is a charge 

management controller for lithium-ion and lithium-polymer batteries. Its datasheet is 

found here . The physical dimension is shown below. 

 

 
Note that the dimensions are in millimeters. The default units for PADS are Mils, or 

0.001 inch. To change this go to Tools > Options, select the Global tab and click 

Metric. 

http://ww1.microchip.com/downloads/en/DeviceDoc/22036b.pdf


 

3.4 Select the Grids tab and change the Design and Display grid X: and Y: settings to 

0.05mm as shown below. Click OK to exit the Options window 

 

 
 

The outline for the body of the part is designated by dimensions D – overall length = 3.10 

(max), and E1 – Molded package width = 1.80(max). To draw this rectangle select the 

Drafting Toolbar  and then select the 2D Line   button. Draw this box about the 

origin,  , by clicking on points (-1.55, -.9),  

(1.55,-.9), (1.55,.9), (-1.55,.9), then right-clicking and selecting Complete. You should 

have a rectangle as shown below. 

 

 
 

3.4 Note that the outline is currently on the Top layer as shown in the layer drop-down 

box, , in the upper left corner of the Layout window. This box 

should be on the silkscreen layer to show the part outline without  being an unwanted 

conductive surface. Press the Esc key to leave any tool that may be selected, right-click 

in the Decal window and choose Select Shapes. Click the box and note that its color 



changes from red to white to indicate that it has been selected. . Right-click and select 

Properties. Then window should appear as shown below. 

 

 
 

We want this shape to serve as the body outline on the silkscreen and to also change the 

line thickness to a thinner outline, so change the Width to .15, the Layer to Silkscreen 

Top and click OK. 

 

3.5 We will now add the terminals to the outline. Click the Terminal  button. Click 

OK on the Add Terminals window to accept default. The window will close. Place the 

cursor somewhere close to the outline and click. Press the Esc key to deactivate the 

terminal mode. Right-click in the layout area and choose Select Terminals . Click on the 

terminal; it changes to solid white. You can move it by holding the left mouse button and 

dragging it to the desired location. 

 

While it is selected, right-click the mouse and choose Pad Stacks. The window shown 

below will pop up. This window allows you to change the pad parameters to match those 

required by your device.  

 



  
 

3.6 Examine the part diagram and note that the lead width, designated “b”, is 0.51mm 

(max) and the Footprint, designated “L1”, is 0.80mm (max). Remember that we need the 

pad to extend beyond the end of the lead for soldering purposes, so add an extra .12mm 

to the footprint length, so we end up with a pad dimension of 0.51mm x 0.92mm. First 

click the rectangular pad,  , in the Parameters box. Change the following so that the 

Pad Stack Properties for Pin is as shown below: 

 Drill size: -  0 (no hole) 

 Width:  - 0.51 

 Length: - 0.92 

 Orientation: - 90 

 

 
 

Click OK. The layout area should resemble that shown below. 

 



 
 

3.7 Copy the pad by typing CTRL + C. Paste four more pads in the general locations 

indicated by the part layout by typing CTRL + V, moving the outline as desired, and 

clicking the left mouse button to place. Your part layout should resemble that shown 

below. 

 

 
 

3.8 The pads must now be precisely placed for proper alignment. Use the X-Y coordinate 

indicators shown in the bottom right corner of the display. Remember that we drew the 

chip outline to match the body of the device and centered about the origin. Move pin 2 so 

that the center of the pad lies on the X-coordinate of 0 and the top horizontal edge lies 

along the midpoint of the body outline, corresponding to the left side of the L1 dimension 

of the device layout.  

 

The “e” dimension from the device layout is the center-to-center, or pin pitch 

measurement which is 0.95mm. Select pin 1 and drag it so that the X-coordinate is  

-0.95; select pin 3 and center it on 0.95, aligning the top horizontal edge on the midpoint 

of the body outline. Position pins 4 and 5 to the X-coordinates of 0.95 and   -0.95 

respectively, aligning the bottom horizontal edge of both with the midpoint of the body 

outline. 

 

To move the text, change the selection mode to Select Text/Drafting and drag the text as 

desired . To move the pin numbers change the selection mode to Select Terminal 

Name/Number. Your device should resemble that below. 

 



 
 

3.9 Save the part by clicking File > Save Decal and entering the library destination and 

name of the pcb decal as desired, similar to that shown below and click OK.. 

 

 
 

Click Yes to create new Part Type. Click OK, ignore the error message, re-enter the PCB 

decal name, and click OK. 

 

Click File > Exit Decal Editor to exit. Exit Layout and Start PADS Logic. Refer to 

Section 3 to create a schematic picture for the part. 

 

 

 


