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MultiSpec Tutorial:   

Visualizing Growing Degree Day (GDD) Images 

 

Background:  

This tutorial illustrates how MultiSpec can me used for handling and analysis of general 
geospatial images. The image data used in this example is not multispectral data 
collected by a satellite or aircraft or the results of analysis of those data. Rather it is a 
geospatial image derived from gridded data obtained from the Applied Climate 
Information System (ACIS); the data is derived from measurements collected by many 
weather stations.  More information about how this image data file was generated can 
be found at: 

https://mygeohub.org/groups/u2u/File:Growing_Degree_Days_Details_Behind_Data.pdf 

Requirements:  

• MultiSpec© software application  
(MultiSpec for Macintosh or Windows can be downloaded at: 
https://engineering.purdue.edu/~biehl/MultiSpec/index.html 

• “gdd_2012_accumulated.tif” image and “STATES.SHP” shape file are 
included in a zip file associated with tutorial 10 from the MultiSpec 
tutorial site at: 
https://engineering.purdue.edu/~biehl/MultiSpec/tutorials.html 
Note that this zip file is about 80 MB. It will expand to 150 MB. 

In this tutorial, the MultiSpec© image processing software will be used to: 

• Display a GDD geotiff file and familiarize yourself with the content of the 
GDD image data 

• Overlay a shape file on the GDD image for a spatial reference of a site 
location 

• Plot accumulated GDDs data per day for a selected year (Year 2012 will 
be used in this tutorial as an example) 

• Create a new image representing the accumulated GDDs from a specific 
(planting) date.  

• “Animate” the single channels representing accumulated GDDs for each 
day of the year.  
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1. Growing Degree Day (GDD) Data 

Growing Degree Days (GDD), also called Growing Degree Units (GDUs), are a 

heuristic tool in phenology. GDD are a measure of heat accumulation used by 

horticulturists, gardeners, and farmers to predict plant and pest development rates such 

as the date that a flower will bloom or a crop reach maturity. Growing degree days take 

aspects of local weather into account and allow farmers to predict the plants’ pace 

toward maturity [online at: http://en.wikipedia.org/wiki/Growing-degree_day]. 

The general formula for GDD is given in equation 1. GDDs are calculated by taking the 

average of the daily maximum and minimum temperatures compared to a base 

temperature. 

     Equation 1 

In equation 1, Tmax is the highest temperature for the day, Tmin is the lowest temperature 

for the day, and Tbase is the minimum developmental threshold temperature. If the 

average temperature is less than or equal to Tbase, then GDD is equal to zero. Normally, 

any temperature below Tbase is set to Tbase before calculating the average. Also any 

temperature may be set to an upper threshold value before calculating the average 

depending on the plant.  

The GDDs in the example file for this tutorial are calculated using the Modified 

Growing Degree Day method often used for corn. Tbase is 50 degrees and the upper 

threshold for the temperature is 86 degrees. The units are degrees Fahrenheit. 

Each GDD geotiff file displayed in MultiSpec contains 365 (366 in a leap year) layers 

(channels) corresponding to each day during a one year period. Each layer represents 

the accumulated GDD’s starting from day 1 (January 1). For example, GDD’s for layers 1, 

2 and 3 are calculated as: 

 Layer 1 = GDD’s for day 1 
 Layer 2 = GDD’s for day 1 + GDD’s for day 2 
 Layer 3 = GDD’s for day 1 + GDD’s for day 2 + GDD’s for day 3 
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2. Displaying and Visualizing GDD Image Files 

2.1 Start MultiSpec using the icon on the desktop or from MultiSpec in the Startup 

Menu. 

2.2 From the File menu choose Open Image...  A dialog box will open to allow one to 

select the data file one wishes to use. 

2.3 Select “gdd_2012_accumulated.tif” in the GDD MultiSpec Tutorial folder and 

Open, or simply double-click on “gdd_2012_accumulated.tif”. 

2.4 A Display Specification for: dialog box (Figure 1) will appear to allow one to 

choose among various options for the image display.  

 
Figure 1. Set Display Specification dialog box for loading the 

“gdd_2012_accumulated.tif” image. 
 
 Values for Lines and Columns in the Area to Display group provide the image 

dimensions that can be edited by the user if needed. For this tutorial the default 

values will be used which corresponds to the entire scene. These choices will 

display a layer with 362 lines by 579 columns of pixels. In the Display group, 

select 1-Channel Thematic for Display Type and enter the value 122 
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associated with the Channel. These choices will display a single-channel image of 

GDD’s corresponding to May 1, 2012 (channel 122). Select OK. A thematic image 

(Figure 2) will be displayed associated with the accumulated GDD’s (Blue = fewer 

GDDs, Red = more GDDs) for May 1, 2012. The data values are grouped into the 

default number of levels (12) and a legend is displayed to the left of the image 

indicating which palette colors are associated with each range of data. A factor can 

be entered to multiply the data values displayed in the legend to reflect the actual 

measurement unit. Sometimes the data value may be the measurement value times 

100 or 1000. (Note: The 1-Channel Thematic display feature can be considered as a 

supervised 1-channel levels classifier.) 

 
 Figure 2. Thematic image representing accumulated GDDs from January 1 to May 

1, 2012. 
 
 The number of classes in the legend can be changed by the user in the Number of 

display levels from the Enhancement group (12 group classes is the default 

value). One can use the Min/Max User Specified… option to set the min and max 

values for the range of data to be displayed. Black color corresponds to the default 

color for data values less than the minimum and white color corresponds to the 

default color for values greater than the maximum. Tables 1 and 2 in the Appendix 
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show the channel number with corresponding dates for a common year and a leap 

year, respectively. 

2.5 MultiSpec’s toolbar located above the displayed image has two buttons (small 

boxes) representing large ( ) and small ( ) mountains. These are image 

zooming buttons allowing one to zoom in ( ) or out ( ) from the current image 

scale. Just to the left of the image zooming buttons is a reset button ( ) which 

allows to restore the image to its original setting. The current zoom magnification 

is displayed on the bottom right of the MultiSpec application window in the box 

labeled Zoom=. Some other options are to hold the ‘Ctrl’ key down while zooming 

to change the zoom step factor to 0.1 instead of 1 (e.g. from 1.0 to 1.1 to 1.2 etc.), 

providing more control when zooming into the image. (Note: ‘Option’ key on the 

Macintosh version will do this.) 

 
2.6 The user can set different values for Channels to display different dates. In the 

MultiSpec main menu select Processor->Display Image… The Display 

Specification for: dialog box will appear to allow the user to choose the date to 

be displayed (value in Channels within the Display group). The number of 

classes that will be displayed in the thematic map can be changed in the Number 

of display levels option. A gray scale image (Figure 3) can be displayed in 

MultiSpec when changing the Type in the Display group option to 1-Channel 

Grayscale.  
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Figure 3. GDDs Grayscale image for May 1, 2012. Lighter values represent  
more GDDs, while darker values represent fewer GDDs. 

2.7 To display 3 channels (dates), in the Display group of the Set Display 

Specification for (Figure 1): dialog box, select 3-Channel Color option for 

Display Type and the channels values corresponding to the selected dates. 

(Table 2) that will be associated with the Red, Green and Blue Channels 

options. These choices will display the multiple dates combined in an image 

composite. This resulting image illustrates how the GDD accumulates differently 

across the image. Figure 4 illustrates a combination of channel 300 (October 26, 

2012), channel 200 (July 18, 2012) and channel 100 (April 9, 2012). This image 

shows the variability of GDD through the area of interest due to differences in 

accumulated GDD between locations.   
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Figure 4. A combination of three channels (days): channel 300 (October 26), channel 
200 (July 18) and channel 100 (April 10) during the year of 2012. 

 

2.8 To display the 3 channels (days) used to create the GDDs image composite in 

Figure 4 in a side by side channel (days) display, from the Processor menu, 

select Display Image… to bring up the display dialog box. Then, select Side-

by-Side Channels in Type from the Display group. In the Channels option 

from the Display group select Subset…. The list of Channels (days) will appear. 

Deselect all channels by selecting None, then select the three channels (days) to 

be display in the multichannels display. Select OK. A shape file can be overlaid 

onto the image window to spatially identify specific locations. (See section 3 for 

more details about shape files.) However, in a side by side channel display 

(multichannels) the shape file will appear in the first displayed image only. Figure 

5 shows the selected channels (days) displayed side-by-side for comparison 

purposes with a U.S. state shape file overlaid onto the first image (image on the 

left side).  

For additional information refer to Multispec Tutorial: Display and Inspection 

of Image data with MultiSpec (Tutorial 1) and MultiSpec Tutorial: Creating 

Vegetation Indices Images (Tutorial 8) at the web site: 

https://engineering.purdue.edu/~biehl/MultiSpec/tutorials.html 
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Figure 5. Three selected channels (days) displayed side-by-side: channel 300 (October 

26), channel 200 (July 18) and channel 100 (April 10) from 2012. 
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3. Open and Overlay a Shape File 

3.1  With the gray scale image displayed (Figure 3), select from the MultiSpec main 

menu File->Open Image… and select the STATES.shp (or other shape file) that 

was downloaded. You may need to change the filter (Files of type option) in the 

Open Image… dialog box to Shape (*.shp) or All Files (*.*). The shape file 

(US states) will be overlaid onto the image window as illustrated in Figure 6. 

 
Figure 6. STATE shape file overlaid onto the GDDs Grayscale image for May 1, 2012. 

Lighter values represent more GDDs, while darker values represent fewer GDDs. 
 

3.2 A popup menu button for the Windows version will appear next to the zoom 

buttons in the toolbar to allow one to turn the display of the shape file overlay(s) on 

and off. The Overlay popup menu button in the Macintosh version is in the lower 

left of the Image Window.  

3.3 MultiSpec will automatically convert lat-long shape files to respective map 

coordinates for images in Albers Equal Area, Cylindrical Equal Area, 

Equirectangular, Lambert Azimuthal Equal Area, Transverse Mercator, 

Orthographic, Sinusoidal and UTM map projections. MultiSpec first assumes the 

shape file is in the same units as the map projection. If there is no overlap, 

MultiSpec checks if the input shape file units are within the range possible for 

decimal latitude-longitude degrees. If so, MultiSpec assumes the shape file is in lat-

long units and converts them to map projection units. If the converted shape file 

values overlap with the image, then the shape file is overlaid onto the image. If a 
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shape file has been converted, _ltom is appended to the shape file name in the 

overlay list for the window. (Comment: ltom stands for lat-long to meters.) 

 [NOTE: Be aware that MultiSpec assumes the shape file and the image data 

represent the same datum. In other words, no adustments are made for matching 

different datums.] 

3.4 A dialog box for editing the vector line width and color in the Windows version will 

appear when holding the shift key down before selecting the Overlay menu button 

with the left mouse button, and then selecting the shape file overlay to be edited.  

Note that … now follows the overlay name indicating that a dialog box will be 

displayed.  One can obtain this dialog box in the Macintosh version by holding the 

Option key down and selecting the Overlay menu button and then selecting the 

overlay to be edited. 

3.5 The selected shape file can be removed from memory by selecting Edit->Clear 

Overlays from the main menu. Shape files drawn in all open windows will be 

listed. If an open window has an image in geometric (lat-long) projection, shape 

files on these images will be treated as a separate shape files in the Edit->Clear 

Overlay list.  

For Additional information refer to Multispec Tutorial: Overlay Shape Files on 

Image Window at the web site: 

https://engineering.purdue.edu/~biehl/MultiSpec/tutorials.html. 
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4. Plot Accumulated GDDs Data per Day for a Selected Year 

4.1 Select a point in the grayscale image by clicking on the desired location. Go to 

Windows option in MultiSpec main menu and select Selection Graph. A plot of 

the accumulated GDD vs. day of year (Figure 7) will be displayed showing the 

amount of GDD accumulated through time (days of year) for to the selected 

location.   

 

Figure 7. Plot of the accumulated Growing Degree Day vs. day of year 
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5. Create a New Image Representing the Accumulated GDDs from a 
Specific Date 

5.1 GDD data provides the accumulated GDDs based on the start of the year. A new 

image can be created representing the GDD from a specific date (e.g. planting date). 

The steps in this section explain how to illustrate GDDs from a planting date of May 

1, 2012 (Channel 122). 

5.2 Using the image when displayed as multispectral data (not 1-channel thematic), 

select from the MultiSpec main menu Processor->Reformat->Change Image 

File Format…. In the Set Image File Format Change Specifications dialog 

box (Figure 8) select Transform data …. In the Set Reformat Transform 

Parameter dialog box, select Adjust Selected Channels by Selected 

Channels option, and type 122 (May 1, 2012) in the Channel box (red circle in 

Figure 9). This option allows to subtract channel 122 (accumulated GDDs from 

January 1 to May 1, 2012) for all available channels, thus, providing an image which 

represents the accumulated GDDs starting from May 1, 2012 (planting date). Save 

the image in the proper folder and assign a new name. For this example the new 

image name is “gdd_2012_accumulated_May_1”. Figure 10 represents a plot 

of the accumulated GDDs starting on May 1. 2012 (Channel 122 – x axis).  

 
Figure 8. Set Image File Format Change Specifications dialog box.  

Red circle shows the selected Transform Data… option. 
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Figure 9. Set Reformat Transform Parameter dialog box with the Adjust 
Selected Channels by Selected Channels option selected. 

 

 

Figure 10. Illustration of the accumulated Growing Degree Days starting from May 1, 
2012 (planting date) vs. day of year 



MultiSpec Tutorial 10 Visualizing Growing Degree Day (GDD) Images 

Revised 9/10/2015 Page 14 of 18 

 

6. View an “Animation” of how the GDDs accumulate during the year 

One can view an animation of the daily accumulations with a few fairly simple steps. 

6.1 Open gdd_2012_accumulated.tif as described in section 2.  

 - Select 1-Channel Thematic for the Display Type. 

 - Select User Specified… for the Enhancement Min/Max. 

 - In the “Set Specifications for Display Enhancement” dialog box, set Min value to 0 

and Max value to 5500. Then close the Enhancement dialog box by selecting OK. 

 - Enter 24 for the number of display levels. 

 - Select OK to close the “Multispectral Display” dialog box. 

 The result for channel one will be a solid blue image illustrated in Figure 11. The 

image represents the accumulated growing degree days for January 1 for the 

Midwest U.S. There are very few to none in most years. 

 
Figure 11. Illustrating 1-channel thematic display of channel one with  

state boundaries overlaid on the image. 
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6.2 Add State Shape file overlay on the image.  

 - Follow steps as described in step 3. 

 The result will be an image as displayed in Figure 11. 

6.3 Now animate the displayed image. 

 - One can quickly display channel 2 (day 2 or January 2) by striking the right arrow 

key. Each time one strikes the right arrow key, the image being displayed will 

advance to the next channel (or day). Striking the right arrow key has the same affect 

as opening the Display Dialog box and increment the channel by 1 and then selecting 

the OK button. If one strikes the left arrow key, one will go back to the previous 

channel.  

 - If one holds the right arrow key down, one will obtain a “poor man’s” animation as 

the channels are displayed in order. One can view how the growing degree days first 

begin accumulating in the south and then moves to the north as spring progresses. 

 - If one holds the shift key down and strikes the up arrow, the last channel will be 

displayed. If one holds the shift key down and strikes the down arrow, the first 

channel will be displayed. 
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Concluding Remarks 

This tutorial illustrates how MultiSpec can be used to help visualize and study geospatial 
data in general. 

There are many other operations that one can do with MultiSpec including several 
Reformatting processes.  See other tutorials or the MultiSpec Introduction at the 
MultiSpec web site for more information. The MultiSpec web site is: 
https://engineering.purdue.edu/~biehl/MultiSpec/. Or contact Larry Biehl at 
biehl@purdue.edu with questions. 
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APPENDIX 

Table 1. Channel number and corresponding dates for a 365-day year 

Jan Ch Feb Ch Mar Ch Apr Ch May Ch Jun Ch Jul Ch Aug Ch Sep Ch Oct Ch Nov Ch Dec Ch 
1 1 1 32 1 60 1 91 1 121 1 152 1 182 1 213 1 244 1 274 1 305 1 335 
2 2 2 33 2 61 2 92 2 122 2 153 2 183 2 214 2 245 2 275 2 306 2 336 
3 3 3 34 3 62 3 93 3 123 3 154 3 184 3 215 3 246 3 276 3 307 3 337 
4 4 4 35 4 63 4 94 4 124 4 155 4 185 4 216 4 247 4 277 4 308 4 338 
5 5 5 36 5 64 5 95 5 125 5 156 5 186 5 217 5 248 5 278 5 309 5 339 
6 6 6 37 6 65 6 96 6 126 6 157 6 187 6 218 6 249 6 279 6 310 6 340 
7 7 7 38 7 66 7 97 7 127 7 158 7 188 7 219 7 250 7 280 7 311 7 341 
8 8 8 39 8 67 8 98 8 128 8 159 8 189 8 220 8 251 8 281 8 312 8 342 
9 9 9 40 9 68 9 99 9 129 9 160 9 190 9 221 9 252 9 282 9 313 9 343 

10 10 10 41 10 69 10 100 10 130 10 161 10 191 10 222 10 253 10 283 10 314 10 344 
11 11 11 42 11 70 11 101 11 131 11 162 11 192 11 223 11 254 11 284 11 315 11 345 
12 12 12 43 12 71 12 102 12 132 12 163 12 193 12 224 12 255 12 285 12 316 12 346 
13 13 13 44 13 72 13 103 13 133 13 164 13 194 13 225 13 256 13 286 13 317 13 347 
14 14 14 45 14 73 14 104 14 134 14 165 14 195 14 226 14 257 14 287 14 318 14 348 
15 15 15 46 15 74 15 105 15 135 15 166 15 196 15 227 15 258 15 288 15 319 15 349 
16 16 16 47 16 75 16 106 16 136 16 167 16 197 16 228 16 259 16 289 16 320 16 350 
17 17 17 48 17 76 17 107 17 137 17 168 17 198 17 229 17 260 17 290 17 321 17 351 
18 18 18 49 18 77 18 108 18 138 18 169 18 199 18 230 18 261 18 291 18 322 18 352 
19 19 19 50 19 78 19 109 19 139 19 170 19 200 19 231 19 262 19 292 19 323 19 353 
20 20 20 51 20 79 20 110 20 140 20 171 20 201 20 232 20 263 20 293 20 324 20 354 
21 21 21 52 21 80 21 111 21 141 21 172 21 202 21 233 21 264 21 294 21 325 21 355 
22 22 22 53 22 81 22 112 22 142 22 173 22 203 22 234 22 265 22 295 22 326 22 356 
23 23 23 54 23 82 23 113 23 143 23 174 23 204 23 235 23 266 23 296 23 327 23 357 
24 24 24 55 24 83 24 114 24 144 24 175 24 205 24 236 24 267 24 297 24 328 24 358 
25 25 25 56 25 84 25 115 25 145 25 176 25 206 25 237 25 268 25 298 25 329 25 359 
26 26 26 57 26 85 26 116 26 146 26 177 26 207 26 238 26 269 26 299 26 330 26 360 
27 27 27 58 27 86 27 117 27 147 27 178 27 208 27 239 27 270 27 300 27 331 27 361 
28 28 28 59 28 87 28 118 28 148 28 179 28 209 28 240 28 271 28 301 28 332 28 362 
29 29   29 88 29 119 29 149 29 180 29 210 29 241 29 272 29 302 29 333 29 363 
30 30   30 89 30 120 30 150 30 181 30 211 30 242 30 273 30 303 30 334 30 364 
31 31   31 90   31 151   31 212 31 243   31 304   31 365 
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Table 2. Channel number and corresponding dates for a leap year 
 
Jan Ch Feb Ch Mar Ch Apr Ch May Ch Jun Ch Jul Ch Aug Ch Sep Ch Oct Ch Nov Ch Dec Ch 

1 1 1 32 1 61 1 92 1 122 1 153 1 183 1 214 1 245 1 275 1 306 1 336 
2 2 2 33 2 62 2 93 2 123 2 154 2 184 2 215 2 246 2 276 2 307 2 337 
3 3 3 34 3 63 3 94 3 124 3 155 3 185 3 216 3 247 3 277 3 308 3 338 
4 4 4 35 4 64 4 95 4 125 4 156 4 186 4 217 4 248 4 278 4 309 4 339 
5 5 5 36 5 65 5 96 5 126 5 157 5 187 5 218 5 249 5 279 5 310 5 340 
6 6 6 37 6 66 6 97 6 127 6 158 6 188 6 219 6 250 6 280 6 311 6 341 
7 7 7 38 7 67 7 98 7 128 7 159 7 189 7 220 7 251 7 281 7 312 7 342 
8 8 8 39 8 68 8 99 8 129 8 160 8 190 8 221 8 252 8 282 8 313 8 343 
9 9 9 40 9 69 9 100 9 130 9 161 9 191 9 222 9 253 9 283 9 314 9 344 

10 10 10 41 10 70 10 101 10 131 10 162 10 192 10 223 10 254 10 284 10 315 10 345 
11 11 11 42 11 71 11 102 11 132 11 163 11 193 11 224 11 255 11 285 11 316 11 346 
12 12 12 43 12 72 12 103 12 133 12 164 12 194 12 225 12 256 12 286 12 317 12 347 
13 13 13 44 13 73 13 104 13 134 13 165 13 195 13 226 13 257 13 287 13 318 13 348 
14 14 14 45 14 74 14 105 14 135 14 166 14 196 14 227 14 258 14 288 14 319 14 349 
15 15 15 46 15 75 15 106 15 136 15 167 15 197 15 228 15 259 15 289 15 320 15 350 
16 16 16 47 16 76 16 107 16 137 16 168 16 198 16 229 16 260 16 290 16 321 16 351 
17 17 17 48 17 77 17 108 17 138 17 169 17 199 17 230 17 261 17 291 17 322 17 352 
18 18 18 49 18 78 18 109 18 139 18 170 18 200 18 231 18 262 18 292 18 323 18 353 
19 19 19 50 19 79 19 110 19 140 19 171 19 201 19 232 19 263 19 293 19 324 19 354 
20 20 20 51 20 80 20 111 20 141 20 172 20 202 20 233 20 264 20 294 20 325 20 355 
21 21 21 52 21 81 21 112 21 142 21 173 21 203 21 234 21 265 21 295 21 326 21 356 
22 22 22 53 22 82 22 113 22 143 22 174 22 204 22 235 22 266 22 296 22 327 22 357 
23 23 23 54 23 83 23 114 23 144 23 175 23 205 23 236 23 267 23 297 23 328 23 358 
24 24 24 55 24 84 24 115 24 145 24 176 24 206 24 237 24 268 24 298 24 329 24 359 
25 25 25 56 25 85 25 116 25 146 25 177 25 207 25 238 25 269 25 299 25 330 25 360 
26 26 26 57 26 86 26 117 26 147 26 178 26 208 26 239 26 270 26 300 26 331 26 361 
27 27 27 58 27 87 27 118 27 148 27 179 27 209 27 240 27 271 27 301 27 332 27 362 
28 28 28 59 28 88 28 119 28 149 28 180 28 210 28 241 28 272 28 302 28 333 28 363 
29 29 29 60 29 89 29 120 29 150 29 181 29 211 29 242 29 273 29 303 29 334 29 364 
30 30   30 90 30 121 30 151 30 182 30 212 30 243 30 274 30 304 30 335 30 365 
31 31   31 91   31 152   31 213 31 244   31 305   31 366 

 


